Aktuelle Zeit: 16.12.2019 12:40:00

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 39 Beiträge ]  Gehe zu Seite Vorherige  1, 2
Autor Nachricht
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 14:32:34 
Offline
Benutzeravatar

Registriert: 24.10.2011
Beiträge: 3595
@Holger: Kann ich nicht bestätigen.

Hast das selbst Programmierte getestet oder einen normalen Doppelcklick auf die *.trn-Datei? Wenn ersteres: Hast du bei der Parameterübergabe einen relativen Pfad verwendet oder einen absoluten? Wenn letzteres, hast du mögliche Leerzeichen korrekt behandelt?

(Im übrigen funktioniert das übergeben eines relativen Pfades auch weiterhin.)

_________________
Diese Signatur möchte folgendes bekannter machen: ZusiWiki: Führerstände · ZusiWiki: Fahrzeugprojekte · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 15:50:27 
Offline

Alter: 61
Registriert: 18.07.2016
Beiträge: 706
Wohnort: Berlin
Aktuelle Projekte: TriFan/ZusiOSBridge
ZusiMeter 2019
ZusiStart
ZusiObjektAlbum
nette Tools für nette Zusianer
Heute vormittag:

D1989 (Augsburg-Donauwörth)
CAN24000 (Göttingen-Eichenberg)
IC706 (Augsburg-Donauwörth)

- das oben geschilderte Verhalten
- der Rechner lief bereits ein paar Stunden und Zusi war etliche Male vorher schon gestartet worden

eben gerade unmittelbar nach dem Hochfahren des Rechners:
2x D1981 (Augsburg-Donauwörth)

mit einem leicht abgewandelten Verhalten:

- beide male startete der Zug
- beim ersten mal nach F4 Zugriffsverletzung, Zusi lässt nur noch über den Task-Manager beenden
- beim zweiten Mal konnte ich fahren, aber Zusi lässt sich wieder nicht mehr auf regulärem Weg beenden

Für mich deutet das doch irgendwie immer noch auf eine nicht initialisierte Variable hin. Ich kenne diese "Geht, geht nicht"-Fehler nur zu gut aus eigener Erfahrung. Sie sind so verdammt schwer zu finden!

Gruß
Holger

_________________
If you can't fix it with a hammer, it might be an electrical problem ...
Wenn es auch das nicht ist, schreibe an service ät zusi-tools punkt org.
Tool zum Versenden der Log-Dateien (benötigt installiertes E-Mail-Programm auf dem Rechner)


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 16:46:08 
Offline
Administrator
Benutzeravatar

Registriert: 03.07.2002
Beiträge: 29186
Wohnort: Braunschweig
Hat denn noch jemand das Problem?

Carsten


Nach oben
 Profil Website besuchen  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 18:26:29 
Offline
Benutzeravatar

Registriert: 24.10.2011
Beiträge: 3595
m3933 hat geschrieben:
(der Klick aufs Simulationsbild klappt hier schon nicht, geht nur durch Klick aufs Zusi-Symbol in der Taskleiste)
Hierzu noch eine Anmerkung: Es tritt bei mir sporadisch auf, dass Zusi erst auf den 2. Klick reagiert. Beim 1. Klick scheint Zusi stattdessen irgendwas anderes zu machen, evtl. den Buchfahrplan zu markieren (selbst wenn dieser derzeit gar nicht sichtbar ist.) Aber meist tritt das nur einmal pro Zusi-Start auf und danach nie wieder und beim 2. Klick geht es. Es gibt auch keine F2-Probleme oder Zugriffsverletzungen.

Trotzdem möchte ich mich erst mal auf dieses Detail fokussieren: Klappt es bei dir beim 2. Klick?

_________________
Diese Signatur möchte folgendes bekannter machen: ZusiWiki: Führerstände · ZusiWiki: Fahrzeugprojekte · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 19:10:48 
Offline
Benutzeravatar

Alter: 45
Registriert: 24.06.2002
Beiträge: 1995
Wohnort: Schwäbisch Gmünd
Zitat:
Hat denn noch jemand das Problem?
Gerade mal ausprobiert.

- ZusiStart 1.4.0 gestartet
- D1989 ausgewählt und "Ausgewählten Zug fahren" geklickt
- Zusi startet, aber es passiert weiter nichts. Es wird nichts geladen. Es sieht genauso aus, als würde ich Zusi über das Zusi-Icon starten. Ein automatisches Laden des Fahrplans passiert bei mir nicht. Wenn man "Server automatisch starten" anhakt, gehts auch.


Zuletzt geändert von Michael Springer am 09.10.2019 19:34:41, insgesamt 1-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 19:14:35 
Offline

Registriert: 25.07.2017
Beiträge: 75
F. Schn. hat geschrieben:
Trotzdem möchte ich mich erst mal auf dieses Detail fokussieren: Klappt es bei dir beim 2. Klick?
Dieses Verhalten habe ich auch manchmal. Bei "meinem" Problem hilft aber kein zweiter oder mehrfacher Klick.
m3933 hat geschrieben:
Habe jetzt mal auf Standardeinstellungen alle Karten zurückgesetzt: NICHT reproduzierbar.
Sobald "Zugdatenfenster ausblenden" aktiviert ist, sollte das Problem nachstellbar sein, auch ohne Vollbildmodus.
Darauf aufbauend hier nochmal ein anderer Weg zum Nachstellen:
Vorher im Simulator festlegen: Standardeinstellungen, Vollbildmodus
- Doppelklick auf eine *.trn
- nach dem Laden erscheint die Simulation und der Buchfahrplan, es muss nicht aufgegleist werden
- Reaktion auf z.B. F2 (Pause) ist gegeben
- Windowstaste zweimal drücken (Taskleiste wird ein- und ausgeblendet)
- Reaktion auf z.B. F2 (Pause) ist gegeben
Kann beliebig oft wiederholt werden, bis hier ist alles ok.
- nun den Buchfahrplan schließen
- Reaktion auf z.B. F2 (Pause) ist noch gegeben
- Windowstaste zweimal drücken (Taskleiste wird ein- und ausgeblendet)
- Reaktion auf z.B. F2 (Pause) ist NICHT mehr gegeben, auch nicht durch mehrmalige Klicks auf die Simulation
- nach Beenden der Simulation (Maus) erscheint die Zugriffsverletzung

Durch das fehlende Buchfahrplanfenster kommt es zum Fokusverlust.

VG


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 19:31:21 
Offline
Benutzeravatar

Registriert: 24.10.2011
Beiträge: 3595
2x Windowstaste funktioniert bei mir nicht, Zusi bekommt nach dem 2. mal Windows den Fokus nicht mehr von alleine wieder. Aber wenn ich auf das Zusi-Fenster klicke bekommt Zusi den Fokus und alles ist gut.

Ich glaube, wir brauchen noch ein paar mehr Leute, die hier mitmachen. Michael: Kannst du mal nach m3933's Anleitung testen?

_________________
Diese Signatur möchte folgendes bekannter machen: ZusiWiki: Führerstände · ZusiWiki: Fahrzeugprojekte · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 19:47:18 
Offline

Registriert: 25.07.2017
Beiträge: 75
F. Schn. hat geschrieben:
Aber wenn ich auf das Zusi-Fenster klicke bekommt Zusi den Fokus und alles ist gut.
Auch bei geschlossenem Buchfahrplan? Bei mir nicht möglich.

Holger Maaß konnte damals vor über einem Jahr das Problem nachvollziehen, deshalb habe ich diesen Thread damals erstellt.


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 19:49:53 
Offline
Benutzeravatar

Alter: 45
Registriert: 24.06.2002
Beiträge: 1995
Wohnort: Schwäbisch Gmünd
Bei mir verhält es sich wie hier viewtopic.php?p=303201#p303201 beschrieben.

Wenn das Buchfahrplanfenster zu ist, reagiert er nicht auf F2. Aber mit der rechten Maustauste das Kontextmenü aufrufen kann ich. Beende ich dann Zusi, sieht es so aus, als starte er kurze eine 2. Instanz und danach erscheint die Exception.

Michael


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 19:54:33 
Offline
Benutzeravatar

Registriert: 24.10.2011
Beiträge: 3595
m3933 hat geschrieben:
Auch bei geschlossenem Buchfahrplan? Bei mir nicht möglich.
Ja.

Gut, neuer Versuch. MrX hat sicherlich unter Win7 getestet, Carsten vermutlich unter WinXP, Holger unter Win10. Kann man da eine Gemeinsamkeit finden?

_________________
Diese Signatur möchte folgendes bekannter machen: ZusiWiki: Führerstände · ZusiWiki: Fahrzeugprojekte · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: [erledigt] Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 20:00:23 
Offline

Registriert: 25.07.2017
Beiträge: 75
Michael Springer hat geschrieben:
Wenn das Buchfahrplanfenster zu ist, reagiert er nicht auf F2. Aber mit der rechten Maustauste das Kontextmenü aufrufen kann ich. Beende ich dann Zusi, sieht es so aus, als starte er kurze eine 2. Instanz und danach erscheint die Exception.
Perfekt! Ich wollte mich schon aufgeben...

Ich: Win10

Edit: Ich habe mal das [erledigt] entfernt, bezog sich ja eh auf den Start-Bug.

Edit2: Jetzt sind wir schon drei:
Holger Maaß hat geschrieben:
Das ist übrigens nicht (nur) „dein“ Bug. Das Problem mit den F-Tasten kenne ich auch. Es tritt sofort auf, sobald man das Datenfenster öffnet. Danach gibt‘s keine F-Tasten mehr...


Zuletzt geändert von m3933 am 09.10.2019 20:07:46, insgesamt 2-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 09.10.2019 21:21:39 
Offline
Benutzeravatar

Alter: 28
Registriert: 15.03.2004
Beiträge: 2383
Wohnort: Gelsenkirchen
Das einzige, was ich nachstellen kann (Win7), ist der "Neustart" mit anschließender Fehlermeldung beim Beenden (Zugriffsverletzung bei Adresse 00789563, Lesen von Adresse 0000004C). F-Tasten funktionieren durchgehend tadellos, egal ob mit oder ohne Buchfahrplan oder mit zwischenzeitlichem Startmenüaufruf.


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 07.11.2019 17:55:25 
Offline

Registriert: 25.07.2017
Beiträge: 75
Weil das Thema auch hier https://forum.zusi.de/viewtopic.php?p=304292#p304292 erwähnt wurde: Beim Start per *.trn funktioniert bei mir die Führerstandsbedienung per Maustaste (z.B. Wachsam, Pfeifen, usw.) ebenfalls nicht - das Scrollrad (Fahrhebel) funktioniert. Also zusammenfassend gibt es beim Start per *.trn:

- keine Funktion der F-Tasten
- keine Funktion der Maustaste im Führerstand
- beim Beenden eine Zugriffsverletzung

Grüße,
m3933


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 07.11.2019 18:12:27 
Offline
Benutzeravatar

Registriert: 24.10.2011
Beiträge: 3595
Ich glaube ich habe es hier noch nicht erwähnt, aber bei mir gibt es auch keine Nullreference-Fehlermeldung. Und Maus, F-Tasten und alles andere funktionieren auch korrekt.
Ich habe zwar schon viel probiert, aber nur noch mal um uns mal auf eine Strecke zu einigen: Tauchen die Probleme auch beim Streckenbaututorium und Fenstermodus und Zusi direkt nach dem man im Führerstand landet über X schließen auf?

_________________
Diese Signatur möchte folgendes bekannter machen: ZusiWiki: Führerstände · ZusiWiki: Fahrzeugprojekte · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 07.11.2019 19:30:32 
Offline

Registriert: 25.07.2017
Beiträge: 75
F. Schn. hat geschrieben:
Tauchen die Probleme auch beim Streckenbaututorium und Fenstermodus und Zusi direkt nach dem man im Führerstand landet über X schließen auf?
Jawoll.

Ist das Zugdatenfenster geöffnet, klappt hier schon die Mausbedienung nicht und das Schließen über x ebenfalls nicht, nur über Simulation beenden [Zugriffsverletzung].
Ist das Zugdatenfenster ausgeblendet (Optionen), funktionieren F-Tasten, Mausbedienung und Schließen über x solange, wie das Fenster seinen Fokus hat. Danach nicht mehr. Die Zugriffsverletzung kommt am Ende in beiden Fällen.

Edit:
F. Schn. hat geschrieben:
Gut, neuer Versuch. MrX hat sicherlich unter Win7 getestet, Carsten vermutlich unter WinXP, Holger unter Win10. Kann man da eine Gemeinsamkeit finden?
Wenn es nur bei Einigen auftritt: Vielleicht liegt es nicht am Betriebssystem, sondern an der GraKa? Ich habe AMD (vorher VEGA56 jetzt RX5700).


Zuletzt geändert von m3933 am 07.11.2019 20:48:29, insgesamt 1-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 07.11.2019 21:58:16 
Offline
Administrator
Benutzeravatar

Registriert: 03.07.2002
Beiträge: 29186
Wohnort: Braunschweig
Welche Zusi-Version ist das? Es gab mal so einen Fehler auf manchen Rechnern.

Carsten


Nach oben
 Profil Website besuchen  
 
 Betreff des Beitrags: Re: Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 07.11.2019 22:12:36 
Offline
Benutzeravatar

Registriert: 24.10.2011
Beiträge: 3595
Works for 7+3.3.4.6+AMD, 7+3.3.4.6+ATI, 10+3.3.4.0+integriert

Aber: Works not for:
Holger Maaß hat geschrieben:
3.3.4.6
(Edit: Und Holger ist sicherlich auch 10)

_________________
Diese Signatur möchte folgendes bekannter machen: ZusiWiki: Führerstände · ZusiWiki: Fahrzeugprojekte · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat


Zuletzt geändert von F. Schn. am 07.11.2019 22:21:49, insgesamt 2-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 07.11.2019 22:40:31 
Offline

Registriert: 25.07.2017
Beiträge: 75
Fehler bei mir mit Win10+3.3.4.6+AMD


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Start über *.trn-Datei: Zugriffsverletzung
BeitragVerfasst: 08.11.2019 14:00:18 
Offline

Registriert: 25.07.2017
Beiträge: 75
m3933 hat geschrieben:
Fehler bei mir mit Win10+3.3.4.6+AMD
Gerade getestet: Tritt auch bei Nutzung der OnBoard-Grafik auf, also kann man die GraKa wohl ausschließen.


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 39 Beiträge ]  Gehe zu Seite Vorherige  1, 2

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de
[ Time : 0.023s | 14 Queries | GZIP : Off ]