Updates-Anwender-Reaktionen

Hier kann alles Allgemeine rund um Zusi 3 gefragt und beantwortet werden. Neuigkeiten zum Programm werden hier erscheinen.
Nachricht
Autor
Benutzeravatar
Carsten Hölscher
Administrator
Beiträge: 30743
Registriert: 04.07.2002 00:14:42
Wohnort: Braunschweig
Kontaktdaten:

Re: Updates-Anwender-Reaktionen

#281 Beitrag von Carsten Hölscher »

@Matthias: Ist das mit einer neueren Version wieder ok?

Ich würde aus dem jetzigen Stand nach etwas Abhängigkeitstesten (Rückmeldungen im entsprechenden Thread erwünscht) eine neue Hauptversion machen, außer es gibt gerade noch irgendeinen Zustand, der provisorisch ist und einer Behandlung Bedarf. Dann bitte Info.

Carsten

F. Schn.
Beiträge: 4592
Registriert: 24.10.2011 18:58:26

Re: Updates-Anwender-Reaktionen

#282 Beitrag von F. Schn. »

Was sich in der Version 11 geändert hat ist nicht dokumentiert, oder? Edit: Ah, die .10 ist doppelt Dokumentiert, das wird's vermutlich sein.

Carsten Hölscher hat geschrieben:außer es gibt gerade noch irgendeinen Zustand, ... einer Behandlung Bedarf
ETCS? :mua (Nein, Scherz.)

Wäre es nicht sinnvoll, ein XML-Knoten einzubauen, mit dem man die Warnung "Attribut %1 für Knoten %2 nicht erkannt" für Zusi (evtl. mit Ausnahme der Editoren) unterdrücken (oder zur Info- anstatt Warnmeldung zurückstufen) kann? (%1 und %2 wären als Attribute in dem XML-Knoten anzugeben) Es geht um diesen Fall hier: https://forum.zusi.de/viewtopic.php?p=279907#p279907" target="_blank
Wenn du dann wieder einmal etwas am Datenformat änderst, dass nicht wichtig ist, kannst du dann einfach in die XML-Datei schreiben, dass Zusi da nicht meckern soll.
Dieses Feature muss in .0-Versionen vorhanden sein, daher würde ich vorschlagen, das jetzt zu machen.

Edit: Und eine Variante von "Register nicht belegen" wäre denke ich noch jetzt sinnvoll, um den GWB in Unterlüß nicht sperren zu müssen.
Zuletzt geändert von F. Schn. am 16.01.2018 11:57:27, insgesamt 2-mal geändert.

Benutzeravatar
Ulrich Harder
Beiträge: 13
Registriert: 28.02.2016 14:50:43

Re: Updates-Anwender-Reaktionen

#283 Beitrag von Ulrich Harder »

Hallo,

ich habe jetzt mein Problem etwas eingegrenzt und kann es auch sicher reproduzieren. Es handelt sich um ein Speicherproblem im Arbeitsspeicher. Bei mir also reproduzierbar mit Version 3.1.3.10 und jetzt auch 3.1.3.12, gefahren mit Fahrplan SGK_Fahrplan1991_12Uhr-24Uhr Zug Dg53815 Hamm Rbf - Bebra Rbf.

Bekanntlich können 32-Bit Programme nur 4GB adressieren und da Windows intern auch noch etwas belegt, ist je nach System bei ca. 3,5GB Ende. Dies scheint bei mir der Fall zu sein.

Es läuft Windows 10 Home 64Bit mit 16GB RAM, davon genehmigt sich Windows 2.2GB, ResourcenMonitor und NvidiaInspector sind für den Speicherverbrauch unbedeutend gering.

Hier mal der Speicherverbrauch von Zusi während der Fahrt in MB:
Aufgegleist 625
Paderborn 836
Altenbeken 1081
Willebadessen 980
9 Min. Halt, werde überholt
Warburg 908
Hümme 936
Hofgeismar 957
Jetzt steigt der Verbrauch stark an
Grebenstein 1139
Immenhausen 1495
Mönchehof 1526
Hier steigt Zusi aus und wenn ich jetzt rechne komme ich auf 1,5+2,2=3,7GB Speicher. Das konnte nicht gut gehen. Weshalb das anscheinend nur bei mir auftritt, ist mir rätselhaft.

Das solls für heute erstmal gewesen sein, habe jetzt keine Zeit mehr und werde morgen nochmal nachdenken ob mir was einfällt.

MfG
Ulli

Alwin Meschede
Beiträge: 7157
Registriert: 04.11.2001 19:57:46
Aktuelle Projekte: Zusi3 Objektbau
Kontaktdaten:

Re: Updates-Anwender-Reaktionen

#284 Beitrag von Alwin Meschede »

Du kannst zwei Dinge probieren:

- Sicherstellen dass Du wirklich mit Standardeinstellungen unterwegs bist, indem Du mal auf "Standardwerte alle Karten" in den Simulatoreinstellungen klickst.
- Es gab in der Vergangenheit Einzelfälle, wo die Soundkarte für überhöhten Speicherverbrauch verantwortlich war. Du kannst Deine Karte aus der Liste hier raussuchen und die dort beschriebenen Maßnahmen durchführen: http://zusiwiki.echoray.de/wiki/Problem ... nproblemen" target="_blank - Diese Maßnahmen sind zwar eigentlich als Abhilfe bei fehlenden Geräuschen gedacht, wirken aber möglicherweise auch bei deinem Speicherproblem. Wenn es hilft, bitte melden.
Mein Youtube-Kanal: youtube.com/echoray1

Jan
Beiträge: 317
Registriert: 28.11.2007 19:13:51
Wohnort: Stutensee

Re: Updates-Anwender-Reaktionen

#285 Beitrag von Jan »

Ulrich Harder hat geschrieben:Bekanntlich können 32-Bit Programme nur 4GB adressieren
Standardmäßig nur 2 GB. Maximal 4 GB sind möglich, aber nur wenn das Programm das auch unterstützt, was bei Zusi derzeit nicht der Fall ist.
1,5+2,2=3,7GB Speicher
Die 2,2 GB, die sonstige Programme und Windows belegen sind hier nicht relevant, aber da Zusi ja nur maximal 2 GB nutzen kann, ist das Endergebnis das Gleiche.

Ansonsten wäre man damit halt wieder bei diesem Thema.

M. Zschippang
Beiträge: 935
Registriert: 19.08.2006 19:22:34
Wohnort: Königshain (bei Görlitz)

Re: Updates-Anwender-Reaktionen

#286 Beitrag von M. Zschippang »

Hallo Carsten,

vielen Dank. Alles wieder i.O. mit dem Update.

LG Matthias
Die Hände des Töpfers fertigen das Gefäß.
Die Asche seiner Frau vollendet es.

Mario R.
Beiträge: 313
Registriert: 16.09.2015 13:30:47
Aktuelle Projekte: Führerstand 481
Wohnort: Landkreis Hof

Re: Updates-Anwender-Reaktionen

#287 Beitrag von Mario R. »

Der Angleicher funktioniert jetzt auch wieder, wie er soll :).

F. Schn.
Beiträge: 4592
Registriert: 24.10.2011 18:58:26

Re: Updates-Anwender-Reaktionen

#288 Beitrag von F. Schn. »

Das Problem ist nicht primär der Speicher- sondern der Adressraumverbrauch von Zusi - der führt dann zum Absturz, wenn er die 2GB sprengt.

Bild

Vielleicht lässt sich auch dieses Problem deutlich verkleinern, indem man den Speichermanager austauscht... (Was auch den Weg zu LAA eröffnen würde.)

Benutzeravatar
Ulrich Harder
Beiträge: 13
Registriert: 28.02.2016 14:50:43

Re: Updates-Anwender-Reaktionen

#289 Beitrag von Ulrich Harder »

Hallo,

@Alwin
vielen Dank für die Hinweise. Die Standardwerte habe ich wieder eingestellt, war meine erste Maßnahme. Für den Sound ist ein VIA VT1708S Chip auf dem Asus-Board zuständig, läuft im Stereo Modus und bisher völlig unauffällig.

@Jan
Das genannte Thema habe ich doch tatsächlich übersehen. Das muß ich wohl auf meine Kappe nehmen, da war ich zu nachlässig. Tröstlich ist allerdings die Tatsache das ich mit dem Problem doch nicht so allein bin wie ich dachte. Jedenfalls ist mir jetzt die Ursache klar.

Ich bitte um Entschuldigung das ich mich hier so breit gemacht habe, werde versuchen mich zu bessern.

MfG
Ulli

Benutzeravatar
Johannes
Beiträge: 2495
Registriert: 14.03.2009 22:36:06
Aktuelle Projekte: Zusitools (http://git.io/zusitools)

Re: Updates-Anwender-Reaktionen

#290 Beitrag von Johannes »

ZusiSim.exe : 3.1.3.12
- F LZB-Befehlsfahrt bei größerem Hsig-Abstand korrigiert
ZusiSim.exe : 3.1.3.14
Sollte das was mit diesem Fehler zu tun haben?
(709) Simulator - LZB hebt 40-km/h-Beschränkung nach Befehlsfahrt nicht auf
Beispiel: Gegengleis-Befehlsfahrt ab Jühnde P702. Die Streckengeschwindigkeit bleibt nach der Befehlsfahrt auf 40 km/h beschränkt, bis zum nächsten Geschwindigkeitswechsel in der Strecke.
Den habe ich mit der 3.1.3.14 naemlich immer noch.

Axel Hölscher
Beiträge: 582
Registriert: 06.12.2012 10:23:58

Re: Updates-Anwender-Reaktionen

#291 Beitrag von Axel Hölscher »

Nein, hier geht es um einen LZB-Befehl, der, wenn er mehr als 50 (?) Meter vor dem Signal gegeben wurde, merkwürdiges Verhalten produzierte.
Viele Grüße

Axel

F. Schn.
Beiträge: 4592
Registriert: 24.10.2011 18:58:26

Re: Updates-Anwender-Reaktionen

#292 Beitrag von F. Schn. »

@Carsten: Ich hatte oben zur Ankündigung zur neuen Version was geschrieben, das ist dann allerdings durch die Speichermeldungen verdrängt worden, daher die Frage, ob ich das noch mal an anderer Stelle schreiben soll, oder in diesem Thema doch sehr allgemeinen Thema antworten?

(Es ging um diese Punkte hier:
  • Hinweis, dass im Changelog das Update von 3.1.3.10 auf 3.1.3.11 versehentlich als 3.1.3.9 auf 3.1.3.10 gekennzeichnet ist
  • Für die nächste Hauptversion hätte ich gerne noch eine Möglichkeit die Meldung "Attribut %1 für Knoten %2 nicht erkannt" für angebene %1 und %2 zu unterdrücken (entweder in jeder Datei einzeln angegeben, oder in einer globalen Datei angegeben). (Relevant für ZPA-Abnahme von Dateien, die mit Beta-Versionen bearbeitet wurden, und daher neue Attribute erhalten haben, die auch weggelassen werden können. Wegen ZPA-Kriterium "Hauptversion" der Wunsch, das noch in der nächsten Hauptversion zu machen.)
  • Für die nächste Hauptversion wäre es gut, "Register nicht belegen" (analog Zusi 2) wieder einzuführen, zumindest für die Fahrstraßentabelle, die Editor-Funktonalität kann man auch auch erst in der Beta einführen, oder komplett auf FstrGen verweisen. (Ralf hat in Zusi 2 die Register-nicht-Belegen-Funktion ja sehr vielseitig eingesetzt, Sinn würde sie also in meinen Augen auf jeden Fall machen. Außerdem würde sie eine Möglichkeit bieten, das Problem mit den Modulübergreifenden Registersperren zu lösen. Entsprechende Lösungen müssten ja wieder mit der letzten Hauptversion kompatibel bleiben.)
)

Benutzeravatar
Johannes
Beiträge: 2495
Registriert: 14.03.2009 22:36:06
Aktuelle Projekte: Zusitools (http://git.io/zusitools)

Re: Updates-Anwender-Reaktionen

#293 Beitrag von Johannes »

F. Schn. hat geschrieben:Für die nächste Hauptversion wäre es gut, "Register nicht belegen" (analog Zusi 2) wieder einzuführen, zumindest für die Fahrstraßentabelle, die Editor-Funktonalität kann man auch auch erst in der Beta einführen, oder komplett auf FstrGen verweisen. (Ralf hat in Zusi 2 die Register-nicht-Belegen-Funktion ja sehr vielseitig eingesetzt, Sinn würde sie also in meinen Augen auf jeden Fall machen. Außerdem würde sie eine Möglichkeit bieten, das Problem mit den Modulübergreifenden Registersperren zu lösen. Entsprechende Lösungen müssten ja wieder mit der letzten Hauptversion kompatibel bleiben.)
Gibt es ueberhaupt eine andere sinnvolle Einsatzmoeglichkeit fuer das Ereignis 35 (Register in Fahrstrasse verknuepfen)? Register ausserhalb der Fahrstrasse darf man damit nicht verknuepfen, da sie nicht wieder freigegeben werden, und Register innerhalb der Fahrstrasse nimmt die Fahrstrassengenerierung eh mit.

Benutzeravatar
Carsten Hölscher
Administrator
Beiträge: 30743
Registriert: 04.07.2002 00:14:42
Wohnort: Braunschweig
Kontaktdaten:

Re: Updates-Anwender-Reaktionen

#294 Beitrag von Carsten Hölscher »

Wenn ich nach Wünschen suche, dann schau ich in den Wünschen-Themen. Es sollte also dort stehen, wenn es im Bewußtsein bleiben soll.
Gibt es ueberhaupt eine andere sinnvolle Einsatzmoeglichkeit fuer das Ereignis 35
Möglicherweise gibt es irgendwelche Spezialitäten, wo man sowas brauchen kann. Kost ja nichts, es drin zu lassen.

Carsten

F(R)S-Bauer
Beiträge: 5858
Registriert: 09.11.2002 02:00:47
Aktuelle Projekte: Sich in die Rente retten...2026...

Re: Updates-Anwender-Reaktionen

#295 Beitrag von F(R)S-Bauer »

Johannes hat geschrieben:Gibt es ueberhaupt eine andere sinnvolle Einsatzmoeglichkeit fuer das Ereignis 35 (Register in Fahrstrasse verknuepfen)? Register ausserhalb der Fahrstrasse darf man damit nicht verknuepfen, da sie nicht wieder freigegeben werden, und Register innerhalb der Fahrstrasse nimmt die Fahrstrassengenerierung eh mit.
Da scheint mir er das Problem der Freigabe zu sein. Könnte man damit nicht das Ungelöste Problem der Übergänge in Bf lösen, wenn die Freigabe geht ?(

mfG

Ralf

F. Schn.
Beiträge: 4592
Registriert: 24.10.2011 18:58:26

Re: Updates-Anwender-Reaktionen

#296 Beitrag von F. Schn. »

Da beide sich nicht im Wünsche-Forum befanden habe ich mal zwei entsprechende Themen im Wünsche-Forum aufgemacht.

Wie gesagt: Ich sehe beide Theman als Rückmeldung auf diese Anfrage an.
Carsten Hölscher hat geschrieben:Ich würde aus dem jetzigen Stand nach etwas Abhängigkeitstesten (Rückmeldungen im entsprechenden Thread erwünscht) eine neue Hauptversion machen, außer es gibt gerade noch irgendeinen Zustand, der provisorisch ist und einer Behandlung Bedarf. Dann bitte Info.

Benutzeravatar
Michael Skupin
Beiträge: 192
Registriert: 01.09.2015 23:35:28
Aktuelle Projekte: Team Süd Strecke Augsburg - Donauwörth
Wohnort: Schmiechen

Re: Updates-Anwender-Reaktionen

#297 Beitrag von Michael Skupin »

Hallo

beim letzten Update verschwindet das Programm Dateiverwaltung komplett und macht nicht mehr weiter. Das betriff auch das Programm Fahrzeug Editor.
Die Programme sind komplett verschwunden
Es existieren lediglich die Verknüpfungen....

Bild

Bild

Es gab keine Fehlermeldungen.

Könnt ihr da bitte ein Workaround bereitstellen...


Grüße
Michael
Alles Wissenwertes und Info´s gibt es auf unserm Blog:

http://www.zusi-team-sued.de

Unsere original Strecken( Bau )Objekte:

https://gallerie.zusi-team-sued.de/index.php

Das Team freut sich auf euren Besuch

Benutzeravatar
Carsten Hölscher
Administrator
Beiträge: 30743
Registriert: 04.07.2002 00:14:42
Wohnort: Braunschweig
Kontaktdaten:

Re: Updates-Anwender-Reaktionen

#298 Beitrag von Carsten Hölscher »

Hat noch jemand sowas gehabt? Mir fehlt etwas die Phantasie, wie das beim Updaten passieren kann.

Carsten

F. Schn.
Beiträge: 4592
Registriert: 24.10.2011 18:58:26

Re: Updates-Anwender-Reaktionen

#299 Beitrag von F. Schn. »

Ohne mit MrX einer Meinung zu sein: Das riecht ganz verdächtig nach Virenschutz.

Benutzeravatar
Michael Springer
Beiträge: 2447
Registriert: 24.06.2002 16:22:44
Wohnort: Schwäbisch Gmünd

Re: Updates-Anwender-Reaktionen

#300 Beitrag von Michael Springer »

Ich hatte auch ein paar kleinere Probleme, dass die Dateiverwaltung nicht gepatcht wurde und in einem Zwischenstand stehengeblieben ist. Taskmanager war mein Freund. Später habe ich händisch erst alle anderen Programme aktualisiert und zum Schluss die Dateiverwaltung. Dann ging es problemlos.

Michael

Gesperrt