Update Ziegler-Tools auf TransDEM 2.6.5

Moderator: Roland Ziegler

Antworten
Nachricht
Autor
Benutzeravatar
Roland Ziegler
Beiträge: 5494
Registriert: 04.11.2001 22:09:26
Wohnort: 32U 0294406 5629020
Kontaktdaten:

Update Ziegler-Tools auf TransDEM 2.6.5

#1 Beitrag von Roland Ziegler »

Eine neue TransDEM-Version ist verfügbar.

Adresse zum Herunterladen: Auf meiner Seite unter Download. Oder auch direkt:
Update Ziegler-Tools 2.2.* - 2.2.1.4 (mit TransDEM 32bit)
Update TransDEM 2.6.2+ - 2.6.5 (64bit)

Das Update ist wieder kumulativ, d.h. Voraussetzung ist nur "Ziegler Tools 2.2.0" und höher, bzw "TransDEM 2.6.2" und höher. Welche exakte Version vorliegt, findet das Update dann heraus. Wenn für eine oder mehrere Dateien angezeigt wird, dass die bereits auf dem neusten Stand sind, so ist das nur eine Information, kein Fehler.

Das Update funktioniert auch für Zusi3-Steam-Kunden.

Geländeformer und Absteckrechner bleiben unverändert.
  • GF-Version 2.2.0.2
  • AR-Version 2.1.0.1
TransDEM-Version 2.6.4.3
  • Unterstützung für belgische hochauflösende LIDAR-Höhendaten. Dazu wurde eine neuer EPSG-Code für das belgische Lambert-Koordinatensystem ergänzt und das Einlesen von GeoTIFF leicht modifiziert, und sog. "planare Konfiguration" flexibler gehandhabt.
    http://geoportail.wallonie.be/catalogue ... 7af92.html
  • Diese Version sollte bereits auf dem neusten Zusi-Stick enthalten sein und wird auch seit einigen Wochen den Zus3-Steam-Kunden angeboten.
TransDEM-Version 2.6.5
  • Manuell eingegebene Georeferenzierungsparameter werden jetzt während einer Sitzung zwischengespeichert und bei der folgenden Datei als Vorbesetzung aufgeführt. Das war ein nachvollziehbarer Wunsch: viewtopic.php?f=74&t=17099&sid=2793cf57 ... 12f10d387f
    Bisher lief das aus Code-Sicht auf der sicheren Seite, alle Parametersätze wurden jeweils komplett zurückgesetzt. Jetzt werden potentiell wiederverwendbare Werte kopiert und wieder eingetragen. Ich hoffe, ich habe dabei alle Varianten abgedeckt.
  • Alle Vektorzeichnungen im Hauptfenster: Koordinatengitter, Dreiecke, Trassen usw. werden jetzt mit Kantenglättung ausgeführt. TransDEM benutzt zwar nicht die GPU, aber Anti-Aliasing gibt es seit vielen Jahren auch über das von mir verwendete GDI+-API für gewöhnliche CPU-Grafik. Wird nun genutzt.
  • Die Koordinatenwerte der Gitterbeschriftung im Hauptfenser sind jetzt besser lesbar.
  • Die Geländeschumnmerung ist nun in der Voreinstellung bereits aktiv. Das kann man wieder abschalten, und die Auswahl wird dann auch in den Benutzereinstellungen abgelegt. Grund das jetzt mal zu ändern ist, dass fast sämtliche Anwender-Screenshots, die man in den diversen Foren von TransDEM sieht, immer nur die flachen DEM-Farben zeigen. Theoretisch steckt auch da zwar schon alle Information drin, die aber ist vom menschlichen Auge kaum auflösbar. Zur Veranschaulichung hier am Schluss ein paar Beispiele von den 1m-Höhendaten aus dem Bereich der Zusi-Stammstrecke Altenbeken - Driburg.
  • Unterstützung für japanische DEMs im GML-Datenformat, einer XML-Variante, und Ergänzung der erforderlichen geodätischen Datums, von TransDEM interpretiert als WGS84-Variante. Es gibt 10- und 5m-Höhendaten. Wer sich daran wagen will, sollte entweder japanisch können oder Online-Übersetzung heranziehen, denn die Webseiten sind einsprachig: https://fgd.gsi.go.jp/download/menu.php
    Man muss ein (kostenloses) Konto registrieren, um Daten herunterladen zu können. Die Daten sind vorpaketiert und über Kartenfenster auswählbar. Leider weisen sie reichlich Löcher auf, sämtliche Wasserflächen fehlen, so dass Nachbearbeitung erforderlich ist. Der schnellste Weg ist vermutlich, mit SRTM-Daten aufzufüllen.
  • Auch in Australien gibt es ein neues geodätisches Datum, was von TransDEM ebenfalls mit WGS84 gleich gesetzt wird. Ein Webportal für Queensland bietet Topokarten und Orthofotos als GeoPDF mit dem neuen Datum. Die TransDEM-Interpretation von GeoPDF wurde entsprechen erweitert.
Altenbeken - Driburg ohne und mit Schummerung:

Bild Bild

Bild Bild

Bild Bild

Benutzeravatar
Günni
Beiträge: 583
Registriert: 21.04.2003 14:22:37
Wohnort: BALE

Re: Update Ziegler-Tools auf TransDEM 2.6.5

#2 Beitrag von Günni »

Hallo Roland,

meine Stick-Version von Transdem (2.5.2.0) lässt sich nicht auf die 64-Bit-Version updaten.
Vermutlich liegt es daran, dass in dieser Version keine 64-Bit-Variante enthalten ist, die geupdatet werden könnte.

Was ist zu tun, um die 64-Bit-Variante nutzen zu können.

Vielen Dank
Günni

Benutzeravatar
Roland Ziegler
Beiträge: 5494
Registriert: 04.11.2001 22:09:26
Wohnort: 32U 0294406 5629020
Kontaktdaten:

Re: Update Ziegler-Tools auf TransDEM 2.6.5

#3 Beitrag von Roland Ziegler »

Günni hat geschrieben: 19.05.2021 20:30:55Was ist zu tun, um die 64-Bit-Variante nutzen zu können.
Mir eine Mail schreiben, mit Deinem TransDEM-Schlüssel als Anhang.

Benutzeravatar
Roland Ziegler
Beiträge: 5494
Registriert: 04.11.2001 22:09:26
Wohnort: 32U 0294406 5629020
Kontaktdaten:

Update Ziegler-Tools auf TransDEM 2.6.5.1

#4 Beitrag von Roland Ziegler »

Ein weiteres kleines TransDEM-Update: 2.6.5.1.

Adresse der Updates zum Herunterladen: Auf meiner Seite unter Download. Oder auch direkt:

Update Ziegler-Tools 2.2.* - 2.2.1.5 (mit TransDEM 32bit)
Update TransDEM 2.6.2+ - 2.6.5.1 (64bit)

Das Update ist wieder kumulativ, d.h. Voraussetzung ist nur die Minimalversion, "Ziegler Tools 2.2.0" und höher, bzw. "TransDEM 2.6.2" und höher. Welche exakte Version vorliegt, findet das Update dann heraus. Wenn für eine oder mehrere Dateien angezeigt wird, dass die bereits auf dem neusten Stand sind, so ist das nur eine Information, kein Fehler.

Geländeformer und Absteckrechner bleiben unverändert.
  • GF-Version 2.2.0.2
  • AR-Version 2.1.0.1
Das Update für Zusi funktioniert auch für Zusi3-Steam-Kunden.

Diese TransDEM-Version wurde mit einem neueren Satz der MS C++-Laufzeitbibliotheken gebaut. Die sind dem Updatepaket beigefügt und sollten mit installiert werden.

TransDEM-Version 2.6.5.1
  • Unterstützung für Irische LIDAR DEMs:
    https://dcenr.maps.arcgis.com/apps/weba ... 8c1572c9f5
    Diese DEMs (DTM, digital terrain model) besitzen die Irische Transversale Mercator-Projektion (ITM), die TransDEM auch schon lange Zeit bekannt ist. Allerdings kommen die Daten, wenn sie als GeoTIFF verpackt sind, nicht mit dem üblichen EPSG-Code zur Bestimmung des Koordinatensystems, sondern spezifizieren die ITM-Projektion durch explizite Parameter. TransDEM wurde erweitert, um dies Parameter zu erkennen und zu verarbeiten.
  • Unterstützung für Polnische LIDAR DEMs:
    https://mapy.geoportal.gov.pl
    Diese DEMs (DTM, digital terrain model) besitzen die Polnische Euref 1992-Projektion (Euref92), TransDEM ebenfalls seit Jahren geläufig. Und enthalten als GeoTIFF den zugehörigen EPSG-Code. Leider gab es noch einen Fehler in TransDEM bei der internen Abbildung der EPSG-Codes auf die Koordinatensysteme, so dass die Projektion nicht erkannt wurde. Der Fehler ist nun beseitigt. Die daten sind auch verfügbar im einfachen ESRI ASCII Grid-Format, allerdings mit unterschiedlich spezifizierte Gitterweite für x und y. statt der üblichen einheitlichen Zellgröße. TransDEM wurde erweitert, um auch damit umgehen zu können.
Screenshot: Irisches 2m LIDAR DEM (DTM) mit Hintergrund Open Topo Map

Bild


Screenshot: Polnisches 1m LIDAR DEM (DTM) mit Hintergrund Open Topo Map

Bild

Benutzeravatar
Christian Spitzhüttl
Beiträge: 676
Registriert: 13.02.2006 16:13:40
Wohnort: VS-Tannheim
Kontaktdaten:

Re: Update Ziegler-Tools auf TransDEM 2.6.5

#5 Beitrag von Christian Spitzhüttl »

Hallo zusammen,

musste heute mein System neu aufsetzen und bisher hat alles geklappt. Nur das Update vom 23.12.2021 für die Ziegler-Tools lässt sich nicht installieren.

TransDEM ist frisch vom Stick installiert und beim versuch das Update zu installieren, gibt dies folgende Info aus:

Code: Alles auswählen

"...\ZieglerTools\Gelaendeformer.exe":
No suitable patch found.
"...\ZieglerTools\Absteckrechner.exe":
No suitable patch found.
"...\ZieglerTools\TransDEM.exe":
No suitable patch found.
"...\ZieglerTools\TransDEMDEU.dll":
No suitable patch found.
"...\ZieglerTools\Dokumentation\TransDEM.pdf":
No suitable patch found.
"...\ZieglerTools\Dokumentation\TransDEM_engl.pdf":
No suitable patch found.
Stehe auf dem Schlauch. :dead
Aktuelle Projekte:
  • Zusi3 · Streckenprojekt "Rund um Tuttlingen" (Auf Eis)
  • Zusi3 · Schlepptriebwagen NE81 - Baureihe 626

Benutzeravatar
Christian Spitzhüttl
Beiträge: 676
Registriert: 13.02.2006 16:13:40
Wohnort: VS-Tannheim
Kontaktdaten:

Re: Update Ziegler-Tools auf TransDEM 2.6.5

#6 Beitrag von Christian Spitzhüttl »

Update hat inzwischen geklappt.

Das Update vom 23.12.2021 lässt sich nicht direkt auf die Zusi Stick-Version installieren. Habe auf meiner Externen Festplatte noch ein Update "ZieglerTools-2.2-Upd-Setup.exe" gefunden,
welches sich hat Installieren lassen und im Anschluss konnte das Update vom 23.12.2021 installiert werden.

Christian
Aktuelle Projekte:
  • Zusi3 · Streckenprojekt "Rund um Tuttlingen" (Auf Eis)
  • Zusi3 · Schlepptriebwagen NE81 - Baureihe 626

Antworten