Aktuelle Zeit: 10.12.2018 19:37:57

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 7 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Bool´sche Funktion liefert kein passendes Ergebnis
BeitragVerfasst: 11.11.2017 17:24:17 
Offline

Registriert: 25.11.2009
Beiträge: 100
Wohnort: 33442 Herzebrock
Aktuelle Projekte: Modul Herzebrock
Hallo Community,

zur Umsetzung steht folgendes Gebäude an:

Bild

Um die Mauer- und Fenstervertiefungen zu realisieren, habe ich mir ein entsprechendes Schnittobjekt zur Benutzung mit der Bool´schen Funktion erstellt:

Bild

Nach dem Ausführen der Bool-Funktion und dem Verschieben des Schnittobjektes vom Tatort wird in der Wireframe-Ansicht nur der linke Bereich halbwegs richtig angezeigt:

Bild

Die Ansicht im Solid_Modus zeigt sich total unbeeindruckt:

Bild

Wo liegt der Fehler?

Müssen Schnittkörper die aus mehreren Teilen bestehen speziell erstellt werden?


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Bool´sche Funktion liefert kein passendes Ergebnis
BeitragVerfasst: 11.11.2017 19:01:59 
Online
Benutzeravatar

Alter: 67
Registriert: 04.10.2003
Beiträge: 2029
Wohnort: Brühl (Baden)
Reinhard Raschke hat geschrieben:
Wo liegt der Fehler?
Hallo Reinhard,

der Fehler (oder eher der Irrtum) liegt m.E. darin, dass unsere Objekte aus Flächen und nicht aus Körpern bestehen, Boole'sche Funktionen aber nur für Körper funktionieren.

Wenn Du so eine gegliederte Fassade hast, musst Du also die Gesamtflläche in die entsprechenden Teilflächen zerlegen. Diese kannst Du dann um den jeweils gewünschten Betrag in Richtung Gebäudeinneres extrudieren, wodurch die Leibungen entstehen. Klingt erst mal kompliziert, aber wenn Du den Dreh raushast, dauert das auch nicht länger als der Bau so eines Schnittobjekts.

M.f.G. Christian


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Bool´sche Funktion liefert kein passendes Ergebnis
BeitragVerfasst: 12.11.2017 07:07:50 
Offline

Registriert: 25.11.2009
Beiträge: 100
Wohnort: 33442 Herzebrock
Aktuelle Projekte: Modul Herzebrock
@ Christian:

Danke, aber nach deinen Ausführungen wäre die bool´sche Funktion eigentlich nutzlos, was mich doch sehr befremden würde.

So habe ich mir den Kandidaten nochmal zur Brust genommen.

Festgestellter gravierender Fehler war, das der größere Schnittkörper den zu schneidenen Körper an der unteren Seite nicht überragt hat.
Blender konnte so nicht feststellen ob die Fläche nun da ist, oder nicht.

Dann habe ich den zusammengesetzten Schnittkörper (insgesamt 3 Cube´s) wieder vereinzelt und mit jedem Teil die boolsche Funktion
durchgeführt.

Ergebnis: Problem gelöst

Bild


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Bool´sche Funktion liefert kein passendes Ergebnis
BeitragVerfasst: 12.11.2017 07:58:45 
Online
Benutzeravatar

Alter: 67
Registriert: 04.10.2003
Beiträge: 2029
Wohnort: Brühl (Baden)
Reinhard Raschke hat geschrieben:
Ergebnis: Problem gelöst

Bild
Hallo Reinhard,

dann interessiert mich natürlich, wie das Ergebnis im Detail aussieht: Kannst Du mal bitte die anderen Objekte unsichtbar schalten, für das selektierte Objetkt in den Edit-Modus wechseln und davon den Screenshot hier einstellen?


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Bool´sche Funktion liefert kein passendes Ergebnis
BeitragVerfasst: 12.11.2017 09:49:17 
Offline

Registriert: 25.11.2009
Beiträge: 100
Wohnort: 33442 Herzebrock
Aktuelle Projekte: Modul Herzebrock
Hallo Christian,

ich hoffe, daß ich alle deine Vorgaben richtig umgesetzt habe. Könntest auch die Datei kriegen, ist ja kein Geheimprojekt.

Bild

Gruß

Reinhard


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Bool´sche Funktion liefert kein passendes Ergebnis
BeitragVerfasst: 13.11.2017 10:44:37 
Online
Benutzeravatar

Alter: 67
Registriert: 04.10.2003
Beiträge: 2029
Wohnort: Brühl (Baden)
Reinhard Raschke hat geschrieben:
Könntest auch die Datei kriegen, ist ja kein Geheimprojekt.
Hallo Reinhard,

nicht nötig. Mich hatten diese schrägen Kanten irritiert, die von einigen der Fensterecken ausgehen, und ich hatte den Verdacht, dass da beim Verschneiden sinnlose Flächen entstehen. Anhand Deines letzten Bildes erkennt man aber, dass das nicht der Fall ist.

M.f.G. Christian


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Bool´sche Funktion liefert kein passendes Ergebnis
BeitragVerfasst: 19.11.2017 19:52:38 
Offline

Registriert: 25.11.2009
Beiträge: 100
Wohnort: 33442 Herzebrock
Aktuelle Projekte: Modul Herzebrock
Im Rohbau (95%): "Das Rote Haus" der Firma Craemer GmbH

Bild


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 7 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de
[ Time : 0.026s | 18 Queries | GZIP : Off ]