Aktuelle Zeit: 25.09.2017 22:31:30

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 339 Beiträge ]  Gehe zu Seite Vorherige  1 ... 13, 14, 15, 16, 17
Autor Nachricht
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 10.03.2017 11:32:11 
Offline
Benutzeravatar

Alter: 42
Registriert: 24.06.2002
Beiträge: 822
Wohnort: Schwäbisch Gmünd
Blender und ich sind noch keine Freunde... aber wir können uns arrangieren. Theoretisch und praktisch klappt es mehr oder weniger.

Bei meinen selbstgebauten Objekten sind die Zahlen der Mipmap-Testtextur immer spiegelverkehrt im 3D-Eddi. Drücke ich in Blender NUM1 zeigt er oben Front Ortho an und im Blender-Koordinatensystem ist z nach oben und x nach rechts. Auch beim Import in den 3D-Eddi kann ich nicht die Voreinstellung Blender benutzen, ich brauche die Einstellung Individuell mit Option Vorzeichen tauschen bei y-Achse wird importiert aus.

Muss ich in Blender das Koordinatensystem irgendwie umstellen? Baue ich in die falsche Richtung? Für Hinweise wäre ich dankbar.

Michael

Bild


Zuletzt geändert von Michael Springer am 10.03.2017 11:33:31, insgesamt 3-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 10.03.2017 11:53:41 
Offline

Registriert: 04.11.2001
Beiträge: 4983
Aktuelle Projekte: Zusi3 Objektbau
Machst Du den Export aus Blender über eine .x-Datei? Dann musst Du als Voreinstellung beim Import in den 3D-Editor auch "x-File" auswählen.

_________________
Wie baut man Zusi3-Addons? - Mein Youtube-Kanal: youtube.com/echoray1


Nach oben
 Profil Website besuchen  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 10.03.2017 12:10:38 
Offline
Benutzeravatar

Alter: 42
Registriert: 24.06.2002
Beiträge: 822
Wohnort: Schwäbisch Gmünd
Ja, ich mache den Export per .x-Datei. Mit der .x Standardeinstellung sind im 3D-Eddi die Texturen auf der falschen Seite. Sprich drehe ich das Schild wie gewohnt, um das Ergebnis zu betrachten, sehe ich die graue Rückseite und das Schild selbst zeigt in die nicht sichtbare Richtung. Hoffe das war verständlich.

Ich hatte diese Problematik Textur auf der falschen Seite von Anfang an und deshalb habe einfach solange in den Import-Einstellungen rumgeklickt, bis die Schilder von der Orientierung so lagen, wie die bereits im Bestand. Deswegen ist mein Workflow sicherlich nicht ganz korrekt.

Michael


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 10.03.2017 12:25:33 
Offline

Registriert: 04.11.2001
Beiträge: 4983
Aktuelle Projekte: Zusi3 Objektbau
Schalt mal in Blender mit Taste N die Toolbar für die 3D View zu. Dort sollte "Backface Culling" angekreuzt sein. Ich habe nämlich irgendwie den Verdacht, dass Du auf der falschen Seite der Faces arbeitest.

Bild

Ansonsten noch gucken, dass es beim Export so aussieht wie hier ("Export selected Objects only" und "Apply Modifiers" sind optional je nach Anwendungsfall):
Bild

_________________
Wie baut man Zusi3-Addons? - Mein Youtube-Kanal: youtube.com/echoray1


Zuletzt geändert von Alwin Meschede am 10.03.2017 12:33:30, insgesamt 2-mal geändert.

Nach oben
 Profil Website besuchen  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 10.03.2017 12:37:22 
Offline
Benutzeravatar

Alter: 42
Registriert: 24.06.2002
Beiträge: 822
Wohnort: Schwäbisch Gmünd
In meinem Beitrag oben sieht man im Screenshot, dass das Backface Culling aktiviert ist. Ich habe mal darunter das Motion Tracking ausgeschaltet, weil es bei Dir nicht aktiv ist, aber das brachte auch keine Änderung mitsich.

Ich hatte am Anfang die Einstellungen wie Du in deinem 1. Blender-Video beschrieben hast gemacht. Ich schau mir das nochmals an, vielleicht habe ich was vergessen. Ich hatte vor 2 Wochen, wo ich begonnen hatte, einfach die neueste Version V2.78 heruntergeladen. Vielleicht liegt es daran.

Michael

Nachtrag:
Sieht auch so bei mir aus:
Bild

Nachtrag 2:
Gerade mal zum Testen V2.69 installiert. Alles genauso. Textur verkehrt rum. Das bedeutet, vielleicht liegt das an der .blend Datei. Ich bau das Ding nochmals neu von vorne. Und dann sehen wir weiter.


Zuletzt geändert von Michael Springer am 10.03.2017 12:51:34, insgesamt 2-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 10.03.2017 18:28:12 
Offline

Registriert: 12.03.2016
Beiträge: 288
Wohnort: Forchheim
Ich habe immer mit diesen Einstellungen importiert.

Bild

Inzwischen nutze ich ausschließlich das Blender ls3 Plugin und komme damit sehr gut zurecht.


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 10.03.2017 20:47:30 
Offline
Benutzeravatar

Alter: 54
Registriert: 14.03.2003
Beiträge: 410
Wohnort: 69245 Bammental
Aktuelle Projekte: Netz Nordbaden, Modul Bergheim
Hallo Michael,

Dein Problem mit den gespiegelten Texturen hatte ich bei meinen ersten Versuchen mit Blender auch.
Ich glaube auch die Ursache des Problems zu kennen.
Zwischen Blender und Zusi sind nämlich die Achsen X und Y vertauscht. Wenn ich Alwins Tutorial richtig interpretiere kommt das aus den Anfängen des Fahrzeugbaus.
Die Frontansicht bei Blender entspricht der X-Achse, die Seitenansicht der Y-Achse. Da sich bei Zusi aber die Züge in X-Richtung bewegen, entspricht dort die Frontansicht der Y-Achse und die Seitenansicht der X-Achse. Wenn Du jetzt versuchst, ein Modell aus Blender mit den gleichen X-Y Richtungen in Zusi zu importieren, entsteht dabei quasi eine Spiegelung um die Diagonale Y=X, damit werden auch die Texturen gespiegelt.

Überprüfen kannst Du das relativ einfach. Ich habe für mich einfach einen Quader in Blender erstellt und diesen mit dem Johannes - Exporter nach Zusi exportiert.
Dabei ist mir dann dieser Zusammenhang aufgefallen, siehe auch die beiden folgenden Screenshots.

Bild

Bild

Sollte ich mit meinen Vermutungen falsch liegen, mögen doch bitte die Experten mich korrigieren.
Aber seit ich diesen Achstausch berücksichtige, habe ich auch keine Probleme mehr mit gespiegelten Texturen beim Export von Blenderobjekten.

Gruß
Wolfgang


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 11.03.2017 11:59:18 
Offline
Benutzeravatar

Alter: 42
Registriert: 24.06.2002
Beiträge: 822
Wohnort: Schwäbisch Gmünd
Ja so ist es bei mir auch. .x-Export heißt Texturen vertauscht, .ls3-Export die Texturen passen. Ich denke, ich werde dann zukünftig mit Johannes ls3-Exporter arbeiten.

Danke für die Unterstützung.
Michael


Zuletzt geändert von Michael Springer am 11.03.2017 11:59:28, insgesamt 1-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 08.05.2017 21:29:40 
Offline
Benutzeravatar

Registriert: 14.03.2009
Beiträge: 1614
Aktuelle Projekte: Zusitools (http://git.io/zusitools)
Ich hatte hier eben ein merkwuerdiges Phaenomen. Das Modell wird per Mirror-Modifier an der x-Achse gespiegelt. Trotzdem ergibt sich eine Asymmetrie bei den UV-Koordinaten (bei der Anzeige in Blender genauso wie nach dem Zusi-Export im 3D-Editor):

Bild

Vermutlich ist hier eine Flaeche mit mehr als drei Vertices beteiligt, die nicht in einer Ebene liegen. Dann haengt das Ergebnis von der Triangulierung ab, die Blender vornimmt. Das manuelle Hinzufuegen eines "Triangulate"-Modifiers zum Objekt (Einstellung: Beauty/Beauty) hat das Problem behoben -- und ganz nebenbei das Aussehen des Modells insgesamt leicht verbessert.

Bild


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 08.05.2017 21:35:41 
Offline

Registriert: 21.08.2015
Beiträge: 239
Wohnort: München
Was wird denn das? Ein 610 oder 611 in den bei Einführung aktuellen Produktfarben von DB Regio?


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 08.05.2017 21:38:13 
Offline
Benutzeravatar

Registriert: 14.03.2009
Beiträge: 1614
Aktuelle Projekte: Zusitools (http://git.io/zusitools)
611, beide Farbgebungen


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 11.05.2017 13:07:16 
Offline
Benutzeravatar

Registriert: 14.03.2009
Beiträge: 1614
Aktuelle Projekte: Zusitools (http://git.io/zusitools)
Adventures in Triangulationland, Teil 2. Nachdem ich vorhin den Triangulate-Modifier als Allheilmittel gepriesen habe, muss ich ein wenig zurueckrudern. Nach dem Anwenden des Modifiers berechnet er naemlich die Normalen fuer alle neu entstandenen Dreiecke. Bei nicht exakt planar liegenden n-gons, wie sie unweigerlich beim Arbeiten entstehen, fuehrt das zu unangenehmen Beleuchtungs-Artefakten (links). Ohne den Modifier wird fuer das n-gon eine einzige Flaechennormale berechnet, sodass man die Ungenauigkeiten nach dem Export nicht sieht (rechts).

Bild Bild

Ich habe also den Modifier wieder rausgenommen und die Flaeche mit den problematischen Texturkoordinaten manuell trianguliert.


Zuletzt geändert von Johannes am 11.05.2017 13:10:53, insgesamt 1-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 17.06.2017 16:45:36 
Offline

Alter: 23
Registriert: 27.01.2015
Beiträge: 237
Wohnort: NVE
Aktuelle Projekte: TfV Klasse B
A-Schein Drachen
Hallo,

ich habe da ein kleines Problem in Blender. Bei mir erscheinen im Faceselect Mode die Faces sowohl bei Wireframe als auch bei Solid mit diesem schwarzen Kästchen zum Anklicken in der Mitte. Dummerweise sind die Faces dann auch noch leicht transparent. Ich weiß nicht, wie ich das weg bekommen kann. Ich hätte es gerne wieder normal.

Bild

Grüße
Moritz


Zuletzt geändert von MBT Kuhl am 17.06.2017 16:46:14, insgesamt 1-mal geändert.

Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 17.06.2017 17:18:47 
Offline
Benutzeravatar

Registriert: 14.03.2009
Beiträge: 1614
Aktuelle Projekte: Zusitools (http://git.io/zusitools)
Das ist vermutlich dieser Knopf (Limit Selection to Visible) rechts neben dem Auswahlfeld fuer Vertex/Edge/Face Select: Bild


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 15.07.2017 18:36:28 
Offline

Registriert: 12.03.2016
Beiträge: 288
Wohnort: Forchheim
Kann mir jemand einen Tipp geben, wie ich diese aus der Reihen tanzenden Normalen wieder eingefangen kriege?

Bild

Das Objekt wurde mittels obj.-Import in Blender geladen.

Viele Grüße
Christian


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 15.07.2017 19:17:57 
Offline

Registriert: 12.03.2016
Beiträge: 288
Wohnort: Forchheim
Ein weiteres Mysterium für mich:

Bild

Die Normalen stehen im 90° Winkel und trotzdem kommt es zu falschem Schattenwurf.


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 31.07.2017 20:44:07 
Offline

Registriert: 12.03.2016
Beiträge: 288
Wohnort: Forchheim
Wie bringe ich Blender dazu statt der Nacht- die Tag-UV Map zu rendern?

Bild

Die leuchtenden Fenster haben ein separates Material welches eine zweite UV-Map mit der Nachtextur zugewissen bekommen hat.
Beim Rendern wird nun auf diesen Faces die Nacht- statt der Tagtextur abgebildet. Wie kann ich das ändern?


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 31.07.2017 20:52:20 
Offline
Benutzeravatar

Registriert: 14.03.2009
Beiträge: 1614
Aktuelle Projekte: Zusitools (http://git.io/zusitools)
Kannst du die zweite Textur zum Rendern temporaer deaktivieren (mit dem Haekchen am Textur-Slot)?


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Blender 3D
BeitragVerfasst: 31.07.2017 21:01:28 
Offline

Registriert: 12.03.2016
Beiträge: 288
Wohnort: Forchheim
Super! Danke!
Es funktioniert. Ich hatt es hiermit versucht:

Bild

Das hat jedoch nicht geklappt.


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 339 Beiträge ]  Gehe zu Seite Vorherige  1 ... 13, 14, 15, 16, 17

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de
[ Time : 0.014s | 17 Queries | GZIP : Off ]