? 218 Leistungsschalter gangbar machen

Das Unterforum für Diskussionen rund um die Technik, Bedienung, Konfiguration usw. Das ist auch die erste Anlaufstelle für Bastler mit Fragen zu den Editoren.
Antworten
Nachricht
Autor
Benutzeravatar
Michael_Poschmann
Beiträge: 19470
Registriert: 05.11.2001 15:11:18
Aktuelle Projekte: Finalisierung Großraum Hagen
Wohnort: Str.Km "1,6" der Oberen Ruhrtalbahn (DB-Str. 2550)

? 218 Leistungsschalter gangbar machen

#1 Beitrag von Michael_Poschmann »

Hallo in die Runde,

für mein Fahrpultprojekt möchte ich gerne den Leistungsschalter gangbar machen.
Bei ausgelegtem Leistungsschalter soll der Fahrdiesel beim Aufschalten von Fahrstufen hochdrehen, die Lok sich jedoch nicht in Bewegung setzen, da der Wandler nicht füllt.

Es gibt im Führerstandseditor die Baugruppe "KS Leistung". Hier kann man beim Kombischalter die Wandlerfüllung definieren.
In der Führerstandsgrafik der 218 habe ich mir hilfsweise durch Kopieren eines PZB-Schalters einen "Schalter Leistung" definiert und diesen als grafisches Schaltelement dem KS Leistung zugewiesen.
Wenn ich diesen Schalter per Maus in der Führerstandsgrafik bediene, stellt sich der gewünschte Effekt ein. D.h. in einer Schaltstellung fährt die Lok an, in der anderen dreht lediglich der Motor hoch.

Leider gelingt es mir nicht, diese Funktion per Tastatur oder Pult-Hardware auszulösen.
In der Eingabegeräte-Konfiguration habe ich die Funktion "Leistung aus" auf eine Taste gelegt - die Animation reagiert allerdings nicht auf diesen Tastendruck, und die Lok fährt in jedem Fall los.
Gleiches Verhalten, wenn ich den HW-Schalter des Führerstandes, der über einen Leobodnar korrekt erkannt und ausgelesen wird, entsprechend zuordne. Auch hier reagiert die Animation nicht.

Wo steckt hier der Fehler bzw. welche Abhilfemöglichkeit gibt es?
Hat einer von Euch den Leistungsschalter jemals erfolgreich nutzen können? Oder ist diese Funktion möglicherweise programmseitig noch fehlerhaft?

Auf Hilfestellung hoffend
Michael

Antworten