Aktuelle Zeit: 08.08.2020 09:04:37

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 6 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Autopilot deaktivieren laesst Zug nach vorne springen
BeitragVerfasst: 20.05.2018 13:34:40 
Offline
Benutzeravatar

Registriert: 14.03.2009
Beiträge: 2388
Aktuelle Projekte: Zusitools (http://git.io/zusitools)
Eigentlich wollte ich nachforschen, warum Zuege, die mit v != 0 uebernommen werden, ein paar Frames lang sehr schnell zu fahren scheinen und dann wieder normal schnell fahren. Dabei ist mir allerdings etwas anderes aufgefallen: Deaktiviere ich den Autopiloten, macht der Zug einen Sprung nach vorne. Interessanterweise ist das kein reines Grafikartefakt, sondern manifestiert sich auch im Weg-Zeit-Diagramm des Fahrtenschreibers als Sprung in der ansonsten gleichmaessigen Linie:

Bild

Der Effekt ist naturgemaess bei hohen Geschwindigkeiten und bei niedrigen Frameraten besser sichtbar.

Vielleicht hat das mit dem Ursprungsproblem auch etwas zu tun? Beim Uebernehmen eines bereits fahrenden Zuges wird ja auch der Autopilot ausgeschaltet.


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Autopilot deaktivieren laesst Zug nach vorne springen
BeitragVerfasst: 20.05.2018 13:40:25 
Offline
Administrator
Benutzeravatar

Registriert: 04.07.2002
Beiträge: 30126
Wohnort: Braunschweig
Vermutlich durch die starke fps-Schwankung hervorgerufen, die beim Übernehmen des Zuges entsteht.

Carsten


Nach oben
 Profil Website besuchen  
 
 Betreff des Beitrags: Re: Autopilot deaktivieren laesst Zug nach vorne springen
BeitragVerfasst: 20.05.2018 13:47:17 
Offline
Benutzeravatar

Registriert: 14.03.2009
Beiträge: 2388
Aktuelle Projekte: Zusitools (http://git.io/zusitools)
Carsten Hölscher hat geschrieben:
Vermutlich durch die starke fps-Schwankung hervorgerufen, die beim Übernehmen des Zuges entsteht.
Kann gut sein. Aber beim Deaktivieren des Autopiloten in einem fahrenden Zug gibt es keine fps-Schwankung und der Sprung nach vorne (siehe Fahrtenschreiber) tritt trotzdem auf.


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Autopilot deaktivieren laesst Zug nach vorne springen
BeitragVerfasst: 21.05.2018 11:29:31 
Offline
Administrator
Benutzeravatar

Registriert: 04.07.2002
Beiträge: 30126
Wohnort: Braunschweig
Das muss aber ein Einzelfall sein, normalerweise führt das nicht zu Sprüngen.

Carsten


Nach oben
 Profil Website besuchen  
 
 Betreff des Beitrags: Re: Autopilot deaktivieren laesst Zug nach vorne springen
BeitragVerfasst: 21.05.2018 12:42:24 
Offline
Benutzeravatar

Registriert: 14.03.2009
Beiträge: 2388
Aktuelle Projekte: Zusitools (http://git.io/zusitools)
Carsten Hölscher hat geschrieben:
Das muss aber ein Einzelfall sein
Ohne auf diesem eher harmlosen Effekt unnoetig rumreiten zu wollen: Ich kann das in 100% der Faelle reproduzieren.

Mag jemand anderes das ausprobieren, um auszuschliessen, dass es an meinem Recher liegt? Radienteststrecke starten, einen Zug auswaehlen und etwa im Sekundentakt den Autopiloten aktivieren und wieder deaktivieren. Beim Deaktivieren gibt es jedes Mal einen merklichen Sprung in der Darstellung (sieht man sehr schoen z.B. an der Oberleitung). Bei hoeheren Frameraten ist das irgendwann nicht mehr sichtbar, daher sollte man die Framebremse so bei 20-40 stehen haben.

Da der Effekt bei niedriger Framebremse besser sichtbar ist, koennte ich mir vorstellen, dass genau einen Frame lang was schiefgeht -- also z.B. der Zug sowohl durch das Autopilot-Antriebsmodell als auch das Spieler-Antriebsmodell fortbewegt wird und dadurch quasi doppelten Schub erhaelt.


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Autopilot deaktivieren laesst Zug nach vorne springen
BeitragVerfasst: 27.09.2018 19:33:30 
Offline
Benutzeravatar

Registriert: 05.11.2001
Beiträge: 19105
Wohnort: Str.Km "1,6" der Oberen Ruhrtalbahn (DB-Str. 2550)
Aktuelle Projekte: Westhofen-Hagen und Nebenstrecken
Effekt ist auch bei mir reproduzierbar. Und von Dir ja jetzt unter Nutzung der Zusi-Raumzeitkrümmung für ein produktives Tool verwendet. Auch wenn das wahrscheinlich nicht die Absicht Deiner Grundlagenforschung war...

Grüße
Michael


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 6 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de
[ Time : 0.021s | 16 Queries | GZIP : Off ]