Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

Hier bitte Programmierfehler der Zusi-Software melden.
Antworten
Nachricht
Autor
Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#1 Beitrag von Ben149 »

Hallo zusammen,

Wenn ich den Sim starte, dann öffnet sich automatisch das F7-Fenster, welches Blank bleibt, aber die Zugdaten sehe ich, wenn ich umschalte. Damit auch die Zn. Aber nicht nur das EbuLa Gerät bleibt blank, sondern ich kann auch im exportierten ZusiDisplay keinen Fahrplan öffnen.

es ist weder Zug, noch Fahrplanabhängig, das habe ich bereits ausprobiert. Net.Core ist auf dem aktuellen Stand und sowie den Sim als auch ZusiDisplay als Admin zu laufen hat auch nichts gebracht.

Würde mich freuen wenn mir jemand helfen kann, so langsam verzweifel ich

Benutzeravatar
F. Schn.
Beiträge: 6668
Registriert: 24.10.2011 18:58:26

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#2 Beitrag von F. Schn. »

Ben149 hat geschrieben: 27.03.2024 16:12:57 Net.Core ist auf dem aktuellen Stand
Falsch Antwort. Welche Versionen sind von .Net 32 bit und von .Net 64 bit installiert? Ist von beiden 6.0.28/6.0.321 installiert, oder nur Version 8.0.3/8.0.200 (wenn du von aktuell sprichst) oder nur Versionen kleiner 3? (Den Begriff .Net Core wurde eigentlich für Versionen kleiner 3 verwendet. Uneigentlich kann er aber an verschiedenen Stellen auch auftauchen.)

Edit: Ergänzung:
* Werden unter Zusi->Fahrplan erstellen->Buchfahrplan testen->DLL auswählen die Namen der DLL angezeigt?
* Wenn ja: Werden unter Öffentliche Dokumente\Zusi3\Temp Dateien mit der Endung .error.txt angelegt?
Diese Signatur möchte folgendes bekannter machen: ZusiWiki · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat

Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#3 Beitrag von Ben149 »

F. Schn. hat geschrieben: 27.03.2024 17:56:30
Ben149 hat geschrieben: 27.03.2024 16:12:57 Net.Core ist auf dem aktuellen Stand
Falsch Antwort. Welche Versionen sind von .Net 32 bit und von .Net 64 bit installiert? Ist von beiden 6.0.28/6.0.321 installiert, oder nur Version 8.0.3/8.0.200 (wenn du von aktuell sprichst) oder nur Versionen kleiner 3? (Den Begriff .Net Core wurde eigentlich für Versionen kleiner 3 verwendet. Uneigentlich kann er aber an verschiedenen Stellen auch auftauchen.)
32 bit ist 8.0.203
64 bit ist 7.0.100-preview6.22352.1

Was mich aber umso mehr verwundert ist, dass vor ein paar Monaten noch alles funktioniert hat und jetzt auf einmal nicht mehr

Benutzeravatar
F. Schn.
Beiträge: 6668
Registriert: 24.10.2011 18:58:26

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#4 Beitrag von F. Schn. »

Also .Net 8 und .Net 6 müssten laut Windows-Apps-Liste parallel installiert werden können. Die Preview von .Net 7 dürfte eher veraltet sein, und klingt eher Problemfördernd, .Net 7 müsste schon lange aus dem 100-Preview-Stadium raus sein, wenn ich mich da noch richtig an die ganzen Versions-Spezial-Konventionen erinnere.

Noch zwei Ergänzende Abfragen:
* Werden unter Zusi->Fahrplan erstellen->Buchfahrplan testen->DLL auswählen die Namen der DLL angezeigt?
* Wenn ja: Werden unter Öffentliche Dokumente\Zusi3\Temp Dateien mit der Endung .error.txt angelegt?
Diese Signatur möchte folgendes bekannter machen: ZusiWiki · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat

Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#5 Beitrag von Ben149 »

F. Schn. hat geschrieben: 27.03.2024 18:16:03 Also .Net 8 und .Net 6 müssten laut Windows-Apps-Liste parallel installiert werden können. Die Preview von .Net 7 dürfte eher veraltet sein, und klingt eher Problemfördernd, .Net 7 müsste schon lange aus dem 100-Preview-Stadium raus sein, wenn ich mich da noch richtig an die ganzen Versions-Spezial-Konventionen erinnere.

Noch zwei Ergänzende Abfragen:
* Werden unter Zusi->Fahrplan erstellen->Buchfahrplan testen->DLL auswählen die Namen der DLL angezeigt?
* Wenn ja: Werden unter Öffentliche Dokumente\Zusi3\Temp Dateien mit der Endung .error.txt angelegt?
Auf welche sollte ich die denn updaten? 6.0.28/6.0.321 oder 8.0.3/8.0.200?

Zur Ergänzung:
Ja
Nein

Benutzeravatar
F. Schn.
Beiträge: 6668
Registriert: 24.10.2011 18:58:26

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#6 Beitrag von F. Schn. »

Auf dem Zusi-Stick oder Zusi-Stick-Ersatz-Ordner sind unter dotNET\6.0 die windowsdesktop-runtime-6.0.13-win-x64.exe und die windowsdesktop-runtime-6.0.13-win-x86.exe. Diese sind erforderlich. (Wenn es stattdessen Version 6.0.28 ist, ist das auch OK.) .Net 8 hingegen sollte zwar nicht stören, aber auch nicht helfen.
Diese Signatur möchte folgendes bekannter machen: ZusiWiki · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat

Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#7 Beitrag von Ben149 »

Ich bin ein Steam Nutzer, meine Bezugsquelle wäre in diesem Fall das große weite Internet

Benutzeravatar
F. Schn.
Beiträge: 6668
Registriert: 24.10.2011 18:58:26

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#8 Beitrag von F. Schn. »

Steam macht das normalerweise ebenfalls (irgendwie) von alleine.
Im Notfall gäbe es die zwei Installer (.Net 6.0 Desktop Runtime) aber auch bei Microsoft zum manuellen herunterladen.
Diese Signatur möchte folgendes bekannter machen: ZusiWiki · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat

Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#9 Beitrag von Ben149 »

Hat alles nichts gebracht. Steam Dateiüberprüfung hat zwar angeschlagen, 3 Fehlerhafte Dateis erneut heruntergeladen, und die Dektop runtimes hatte ich scheinbar schon installiert, habe die jetzt mal repaired, aber der Fehler bleibt weiterhin vorhanden

Benutzeravatar
F. Schn.
Beiträge: 6668
Registriert: 24.10.2011 18:58:26

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#10 Beitrag von F. Schn. »

Okay, dann noch mal zurück zu den ergänzenden Fragen: Wenn dort keine .error.txt-Dateien sind: Werden dann unter Öffentliche Dokumente\Zusi3\Temp PNG-Dateien angelegt?
Diese Signatur möchte folgendes bekannter machen: ZusiWiki · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat

Benutzeravatar
Carsten Hölscher
Administrator
Beiträge: 33426
Registriert: 04.07.2002 00:14:42
Wohnort: Braunschweig
Kontaktdaten:

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#11 Beitrag von Carsten Hölscher »

Welchen Zug fährst Du denn? (Fahrplan, Zugnummer)

Carsten

Herbertla
Beiträge: 411
Registriert: 21.03.2007 17:06:26
Aktuelle Projekte: ZUSI3: Strecke 5903: Nürnberg - Schirnding, aktuell bis Schnabelwaid
Strecke 5904: Nürnberg Irrenlohe, aktuell bis Rehhof
Hauptbahnhof Nürnberg, neverending
Strecke 5902: Schnabelwaid - Bayreuth Hbf
Wohnort: Schwaig bei Nürnberg

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#12 Beitrag von Herbertla »

Ich würde mal testen, ob der Fahrplan stimmt!
Wenn da ein Fehler drin ist, z. B. unbekanntes Signal oder ähnliches, dann kann der Simulator keinen Fahrplan schreiben und damit logischer Weise auch keine Ebula weil die Daten ja aus dem Fahrplan kommen!

Einfach im Simulator den "Aktuellen Fahrplan" bearbeiten, den Zug laden und die Positionen mit "Übernehmen" testen ob die Signale richtig angezeigt werden.

Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#13 Beitrag von Ben149 »

Ja, .png Dateien werden angezeigt.
Züge: Alle (bisher ausprobierten) auf dem Fahrplan Salzkotten Emmerthal Warburg 2021 11-17 Uhr
@herbertla, ich verstehe zwar was du mir sagen möchtest, aber wie ich das probieren soll verstehe ich nicht ganz

Nach ein wenig ausprobieren scheint das ein Fahrplan-Problem zu sein. Bei manchen Fahrplänen geht's, bei manchen nicht :(

Benutzeravatar
F. Schn.
Beiträge: 6668
Registriert: 24.10.2011 18:58:26

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#14 Beitrag von F. Schn. »

Dann fehlt immer noch eine Zugnummer.
Und außerdem bräuchte ich dann so langsam doch ein Bild von dem Fehler. Ich kann mir das nicht mehr wirklich vorstellen.

Aber nur mal vorab: Funktioniert beim Fahrplan namens "Strecknebututorial" beim Üg alles so, wie du dir das vorstellst?
Diese Signatur möchte folgendes bekannter machen: ZusiWiki · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat

Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#15 Beitrag von Ben149 »

Zugnummer: Such dir eine aus dem angegeben Fahrplan aus. Kann 50415 sein, oder 47927 oder oder oder
Was du meinst mit ""Strecknebututorial" beim Üg" Ich verstehe nicht, was du mir sagen willst . . .

Edit: https://cdn.discordapp.com/attachments/ ... 93cbeab4bd&

Benutzeravatar
F. Schn.
Beiträge: 6668
Registriert: 24.10.2011 18:58:26

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#16 Beitrag von F. Schn. »

Also eigentlich ist der Sinn, dass du dir eine Zugnummer aussuchst (z.B. eben den KT50415), und dann bei diesem Zug bleibst, und nicht ein Bild von einem anderen nimmst. ;)

Aber wenn du wirklich den Fahrplan Timetables/Deutschland/Paderborn_Kassel/Salzkotten-Emmerthal-Warburg_2021_11Uhr-17Uhr.fpn meinst, und nicht den Timetables/Deutschland/Paderborn_Kassel/Salzkotten-Hameln-Warburg_2021_11Uhr-17Uhr.fpn, dann hast du in der Tat einen Bug gefunden: Der Fahrplan wurde nämlich mit AddOn202 gelöscht und durch letztgenannten ersetzt. Zusi hätte dich in dem Fall durch gelbe oder Rote Fehlermeldungen darauf aufmerksam machen müssen, dass Zusi die .timetable.xml-Dateien gelöscht hat. Ich habe mal einen entsprechenden Bug angelegt.

Also am besten du gehst auf Öffentliche Dokumente\Zusi3 und löschst mal alle Ordner, die da drinnen sind. Und dann nimmst du den verlängerten Fahrplan Salzkotten-Hameln-Warburg_2021_11Uhr-17Uhr.fpn.
Diese Signatur möchte folgendes bekannter machen: ZusiWiki · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat

Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#17 Beitrag von Ben149 »

Dann mache ich das mal. Aber selbst wenn das funktioniert -> Es ist nicht der einzige Fahrplan wo das auftritt: Mühlbach-Veddel 2020 06 bis 10 Uhr das gleiche. Ich habe jetzt nicht alle Fahrplane ausprobiert, aber das sind die zwei bei denen mir das sofort einfällt

Edit: Reine Interessenfrage, ich bin nicht eingeschnappt oder so, mich interessiert das ernsthaft: Inwiefern macht es einen Unterschied, welche Zugnummer ich aussuche, wenn eh alle den gleichen Fehler haben?

Benutzeravatar
F. Schn.
Beiträge: 6668
Registriert: 24.10.2011 18:58:26

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#18 Beitrag von F. Schn. »

Ist ebenfalls entfallen und gegen Kirchheim-Veddel_2020_06Uhr-10Uhr.fpn ersetzt.

Edit: Weil du nie alle Züge probiert haben kannst, und im Regelfall einen Bias von lieblingszügen hast. Z.B. war ja jetzt auch bei dir "jeder Zug" falsch und es war nur jeder Zug dieser zwei Fahrpläne. Siehe auch: viewtopic.php?p=354632#p354632
Diese Signatur möchte folgendes bekannter machen: ZusiWiki · ZusiSK: Streckenprojekte · YouTube: Objektbau für Zusi · euirc: Zusi-Chat

Ben149
Beiträge: 23
Registriert: 01.06.2022 20:58:03

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#19 Beitrag von Ben149 »

Alles klar!
Zum Edit: Ja klar ich kann nicht alle Züge ausprobieren, und ich bin biased (Bei mir: lokbespannte Züge) Aber wenn ich einen Fehler habe, dann probiere ich ein bisschen aus, um so viele Infos geben zu können wie möglich, und für mich macht es keinen Unterschied wenn eh alle Züge die gleichen Fehler haben. Aber gut zu wissen, danke für die Rückmeldung

Flo Zille
Beiträge: 203
Registriert: 15.05.2018 09:06:32

Re: Buchfahrplanfenster bleibt Leer + keine Züge können in's EbuLa geladen werden

#20 Beitrag von Flo Zille »

Da du ja nicht alle Züge ausprobiert hast (wäre wohl etwas viel verlangt :D ) besteht ein "Risiko", dass es mit manchen Zügen dann eben doch funktioniert, und dann z.B. F. Schn. oder Carsten bei dem Versuch, es nachzustellen, ausgerechnet einen der funktionierenden Züge erwischen. Es ist daher bei jedem Fehler nützlich, wenn alle tatsächlich möglichst identische Züge für die Tests nutzen.

Neben dem von F. Schn. hier schon gefundenen Problem mit den ausbleibenden Fehlermeldungen würde ich noch das grundsätzliche Problem anmerken, dass (inzwischen vor allem Steam-)Nutzer es nicht unbedingt bemerken, wenn sie irgendwelche (oft veralteten) Dateien aus ihrem privaten Verzeichnis laden. Bei Updates über die Dateiverwaltung kommt soweit ich weiß inzwischen eine Warnung, wenn Dateien im privaten Verzeichnis im Konflikt zum Update stehen. Das ist bei uns Steam-Nutzern aber natürlich anders, denn die Dateiverwaltung nutzen wir ja nicht zu diesem Zweck. Vielleicht wäre da noch eine (nicht zu störende) Warnung im ZusiSim hilfreich, mit dem Hinweis, dass das zu Problemen führen kann, sobald eine Datei aus dem eigenen Verzeichnis statt dem offiziellen Bestand geladen wird.

Antworten