Testbericht unter Linux

Hier kann alles Allgemeine rund um Zusi 3 gefragt und beantwortet werden. Neuigkeiten zum Programm werden hier erscheinen.
Nachricht
Autor
mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#361 Beitrag von mitropam »

Update: Seit heute läuft die Version RC4 und zumindest bei den Steuerwagen der RE-Linie Düsseldorf - Köln sieht es im Führerstand recht gut aus. Jedenfalls funktionieren die runden Anzeigen. Ebula meldet jedoch, dass es keine TCP-Verbindung gibt.

https://abload.de/img/sypjsl.jpg

Bei den Anzeigen auf der Lok in Gegenrichtung bleiben die Displays allerdings dunkel:

https://abload.de/img/s3zk68.jpg

Und bei den 411, bei denen mit RC1 schon mal drei Displays geleuchtet hatten, sind zwei jetzt wieder alles dunkel. ?(

https://abload.de/img/s0wk6f.jpg
Zuletzt geändert von Carsten Hölscher am 28.12.2020 00:46:03, insgesamt 1-mal geändert.

Benutzeravatar
Carsten Hölscher
Administrator
Beiträge: 31300
Registriert: 04.07.2002 00:14:42
Wohnort: Braunschweig
Kontaktdaten:

Re: Testbericht unter Linux

#362 Beitrag von Carsten Hölscher »

Ich möchte eigentlich nicht jedes Mal wieder in diesem Thread die Monsterbilder in Links verwandeln müssen, um das Forum lesbar zu halten.

Carsten

Benutzeravatar
Rokolell
Beiträge: 30
Registriert: 23.06.2020 22:29:41
Aktuelle Projekte: Zusi und andere Programme unter Wine zum Laufen bringen. :D
Wohnort: VzG 5900, Km 9,4
Kontaktdaten:

Re: Testbericht unter Linux

#363 Beitrag von Rokolell »

Habe jetzt ZusiDisplay teilweise am laufen, jedoch passiert das hier beim Führerstandswechsel...:

https://i.imgur.com/WSvcHBr.jpg

Dies kann jedoch umgangen werden, wenn man die ZusiDisplays vor dem Wechsel manuell über z.B. Htop abschießt.


Außerdem bekomme ich jetzt an zufälligen Stellen solche Fehler wie:

https://i.imgur.com/yplTUQp.jpg
Zuletzt geändert von Rokolell am 30.12.2020 15:06:54, insgesamt 1-mal geändert.

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#364 Beitrag von mitropam »

Magst Du uns auch verraten, wie Du das hinbekommen hast? ?(

Benutzeravatar
Rokolell
Beiträge: 30
Registriert: 23.06.2020 22:29:41
Aktuelle Projekte: Zusi und andere Programme unter Wine zum Laufen bringen. :D
Wohnort: VzG 5900, Km 9,4
Kontaktdaten:

Re: Testbericht unter Linux

#365 Beitrag von Rokolell »

Kann ich nicht so wirklich. Ich habe in der Steamversion eine Datei verändert (siehe https://forum.zusi.de/viewtopic.php?p=319075#p319075 ) und das Programm mit Proton gestartet. :rolleyes:

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#366 Beitrag von mitropam »

Dank der neuen Möglichkeit des Direktaufrufs von ZusiDisplay aus dem Menü ist es nun relativ bequem möglich, sich zumindest das Hauptdisplay von ZusiDisplay-Fahrzeugen passend einzublenden. Wenn man es ungefähr in die richtige Größe bringt und dann den Rahmen ausblendet, sieht das auch schon recht gut aus. Aber nicht vergessen, vorher noch den Server unter "Konfiguration -> Netzwerk" zu starten. 8)

Benutzeravatar
Rokolell
Beiträge: 30
Registriert: 23.06.2020 22:29:41
Aktuelle Projekte: Zusi und andere Programme unter Wine zum Laufen bringen. :D
Wohnort: VzG 5900, Km 9,4
Kontaktdaten:

Re: Testbericht unter Linux

#367 Beitrag von Rokolell »

Hast du mal probiert die USB-Version über Proton laufen zu lassen?

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#368 Beitrag von mitropam »

Bin ich noch nicht zu gekommen. Leider gibt es auch sehr unterschiedliche Anleitungen, wie man Proton auf Ubuntu installiert. Da bin ich noch nicht ganz durchgestiegen.

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#369 Beitrag von mitropam »

Anscheinend hat sich bei wine mal wieder etwas geändert. Beim Programmstart kommt nun die Fehlermeldung:

Code: Alles auswählen

wine: Read access denied for device L"\\??\\Z:\\", FS volume label and serial are not available.
Und in der Tat gibt es auch kein Laufwerk L mehr:

Code: Alles auswählen

user@myhome:~$ ll .wine/dosdevices/
insgesamt 8
drwxrwxr-x 2 user user 4096 Mär  7 22:26 ./
drwxrwxr-x 4 user user 4096 Mär  7 22:26 ../
lrwxrwxrwx 1 user user   10 Okt 18 21:54 c: -> ../drive_c/
lrwxrwxrwx 1 user user   12 Jan 16 22:44 com33 -> /dev/ttyACM0
lrwxrwxrwx 1 user user    8 Okt 18 21:55 d:: -> /dev/sdd
lrwxrwxrwx 1 user user    8 Okt 18 21:55 e:: -> /dev/sdh
lrwxrwxrwx 1 user user    8 Okt 18 21:55 f:: -> /dev/sde
lrwxrwxrwx 1 user user    8 Okt 18 21:55 g:: -> /dev/sr0
lrwxrwxrwx 1 user user    8 Okt 18 21:55 h:: -> /dev/sdg
lrwxrwxrwx 1 user user    8 Okt 18 21:55 i:: -> /dev/sdf
lrwxrwxrwx 1 user user    9 Okt 23 09:50 j:: -> /dev/sdf1
lrwxrwxrwx 1 user user    1 Okt 18 21:54 z: -> //
Könnte man ja mit winecfg einrichten. Nur wo muss es dann hinzeigen?

Benutzeravatar
Johannes
Beiträge: 2631
Registriert: 14.03.2009 22:36:06
Aktuelle Projekte: Zusitools (http://git.io/zusitools)

Re: Testbericht unter Linux

#370 Beitrag von Johannes »

Er schaut nach Laufwerk "Z:", nicht "L:". Das gibt es weiterhin. Wo hat es denn bisher hingezeigt?

War das nach einem Wine-Update? Von welcher Version auf welche Version?

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#371 Beitrag von mitropam »

Wine ist jetzt 6.3 und war vorher 6.1. Wo z vorher hingezeigt hat, kann ich nicht sagen. Jetzt zeigt es auf das Rootverzeichnis.

Benutzeravatar
Rokolell
Beiträge: 30
Registriert: 23.06.2020 22:29:41
Aktuelle Projekte: Zusi und andere Programme unter Wine zum Laufen bringen. :D
Wohnort: VzG 5900, Km 9,4
Kontaktdaten:

Re: Testbericht unter Linux

#372 Beitrag von Rokolell »

Z: muss auf / zeigen, nicht auf //.
Kann man auch in winecfg festlegen.

Benutzeravatar
Johannes
Beiträge: 2631
Registriert: 14.03.2009 22:36:06
Aktuelle Projekte: Zusitools (http://git.io/zusitools)

Re: Testbericht unter Linux

#373 Beitrag von Johannes »

Das sollte kein Problem sein. Viel wichtiger: Was konkret funktioniert denn nicht? Also außer dass diese Meldung kommt. Startet Zusi nicht mehr?

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#374 Beitrag von mitropam »

Johannes hat geschrieben: 08.03.2021 15:29:58 Das sollte kein Problem sein. Viel wichtiger: Was konkret funktioniert denn nicht? Also außer dass diese Meldung kommt. Startet Zusi nicht mehr?
Genau, Zusi und die Dateiverwaltung starten nicht mehr. Z zeigt übrigens auf /.

Bild

F. Schn.
Beiträge: 4825
Registriert: 24.10.2011 18:58:26

Re: Testbericht unter Linux

#375 Beitrag von F. Schn. »

Rufst du Zusi über C:\ oder über Z:\ auf?

(Hintergrund: Für mich macht es - auf den ersten Blick, Johannes ist da evtl. der bessere Experte - eigentlich keinen Sinn, dass diese Meldung kommt, weil es in meinen Augen wenig Sinn macht, dass Zusi oder eine DLL diese Werte für Z:\ abfragt. Außer der Kopierschutz versucht versehentlich seine Kopierschutz-Prüfung mit Z:\ anstatt C:\ zu machen. Aber dazu kenne ich sowohl Wine als auch den Kopierschutz nicht genau genug.)

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#376 Beitrag von mitropam »

Ich hatte Zusi bislang immer mit

Code: Alles auswählen

wine /pfad_zu_zusi/Zusi3/ZusiSim.exe
aufgerufen.

Benutzeravatar
Johannes
Beiträge: 2631
Registriert: 14.03.2009 22:36:06
Aktuelle Projekte: Zusitools (http://git.io/zusitools)

Re: Testbericht unter Linux

#377 Beitrag von Johannes »

Da gab es eine Verhaltensänderung in Wine 6.3. Kannst du bis auf weiteres mit Wine 6.2 arbeiten?

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#378 Beitrag von mitropam »

Das ist wohl der Fluch der automatischen Aktualisierungsverwaltung. Aber die Pakete stehen ja noch auf https://dl.winehq.org. Kann ich manuell runterladen und nochmal installieren. Wirds denn bei Zusi ein Update geben, so dass man wieder die aktuelle Wine-Version nutzen kann?

F. Schn.
Beiträge: 4825
Registriert: 24.10.2011 18:58:26

Re: Testbericht unter Linux

#379 Beitrag von F. Schn. »

Johannes hat geschrieben: 08.03.2021 20:26:25 Da gab es eine Verhaltensänderung in Wine 6.3. Kannst du bis auf weiteres mit Wine 6.2 arbeiten?
Rein aus Interesse: In welchem Bereich?

mitropam
Beiträge: 120
Registriert: 01.10.2015 21:10:08

Re: Testbericht unter Linux

#380 Beitrag von mitropam »

Ziemlich viele Änderungen, siehe https://www.winehq.org/announce/6.3

Antworten