Zusi 3 Demo 3.03 - Installation Problem

Hey folks, everyone speaking English may write in this category!
Nachricht
Autor
Stephan/Taschi
Beiträge: 1050
Registriert: 30.10.2009 11:40:27
Aktuelle Projekte: Zusi boykottieren, gelegentlich mal gesperrt sein

Re: Zusi 3 Demo 3.03 - Installation Problem

#21 Beitrag von Stephan/Taschi »

That begs the question of why exactly Zusi isn't an Unicorn... um... Unicode program.

Benutzeravatar
Johannes
Beiträge: 2631
Registriert: 14.03.2009 22:36:06
Aktuelle Projekte: Zusitools (http://git.io/zusitools)

Re: Zusi 3 Demo 3.03 - Installation Problem

#22 Beitrag von Johannes »

Stephan/Taschi hat geschrieben:That begs the question of why exactly Zusi isn't an Unicorn... um... Unicode program.
AFAIK in not-so-recent Delphi versions you have to jump through some hoops to get decent Unicode support.

That said, I don't even know for sure whether the problem is related to ANSI codepages or some other encoding stuff. But it might be.

Don Johnson
Beiträge: 56
Registriert: 05.09.2009 12:22:33

Re: Zusi 3 Demo 3.03 - Installation Problem

#23 Beitrag von Don Johnson »

Have you already tried setting the "Language for non-Unicode programs" to "German (Germany)"? You can do so in the Control Panel under "Language and Region" in the rightmost tab.
I've tried this but still not working.

Mannerheim
Beiträge: 23
Registriert: 25.06.2007 09:34:56
Wohnort: Warsaw, Poland

Re: Zusi 3 Demo 3.03 - Installation Problem

#24 Beitrag von Mannerheim »

Just wanted to say that changing regional settings to German fixed the problem, I can run the demo now :)

Benutzeravatar
Johannes
Beiträge: 2631
Registriert: 14.03.2009 22:36:06
Aktuelle Projekte: Zusitools (http://git.io/zusitools)

Re: Zusi 3 Demo 3.03 - Installation Problem

#25 Beitrag von Johannes »

Mannerheim hat geschrieben:Just wanted to say that changing regional settings to German fixed the problem, I can run the demo now :)
Great to see that worked! It does seem to be an encoding issue, it is reproducible under Wine too (with the LANG environment variable set), and looks e.g. like this for Russian:

Bild

So, let's wait if the next demo fixes this (or at least gives a more meaningful error message instead of none at all ...)

Best
Johannes
Zuletzt geändert von Johannes am 29.07.2014 16:06:29, insgesamt 1-mal geändert.

Don Johnson
Beiträge: 56
Registriert: 05.09.2009 12:22:33

Re: Zusi 3 Demo 3.03 - Installation Problem

#26 Beitrag von Don Johnson »

Demo version 3.05 still doesn't work with Polish signs.

Benutzeravatar
Carsten Hölscher
Administrator
Beiträge: 31317
Registriert: 04.07.2002 00:14:42
Wohnort: Braunschweig
Kontaktdaten:

Re: Zusi 3 Demo 3.03 - Installation Problem

#27 Beitrag von Carsten Hölscher »

I think I finally could produce this issue on my Win7-computer. So it should work in the next Demo.

Carsten

Benutzeravatar
Carsten Hölscher
Administrator
Beiträge: 31317
Registriert: 04.07.2002 00:14:42
Wohnort: Braunschweig
Kontaktdaten:

Re: Zusi 3 Demo 3.03 - Installation Problem

#28 Beitrag von Carsten Hölscher »

Please try Demo 3.0.6.

Carsten

Don Johnson
Beiträge: 56
Registriert: 05.09.2009 12:22:33

Re: Zusi 3 Demo 3.03 - Installation Problem

#29 Beitrag von Don Johnson »

Finally I can run Zusi3 Demo on my computer. Version 3.0.6 is working with polish signs. Thank you Carsten :respekt

Antworten