Zusi-Forum
https://forum.zusi.de/

Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert."
https://forum.zusi.de/viewtopic.php?f=36&t=14104
Seite 1 von 1

Autor:  MCG [ 06.11.2017 19:33:24 ]
Betreff des Beitrags:  Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert."

Hallo zusammen,

ich hatte Zusi 2 auf meinem aktuellen Rechner (von 2015 mit damals sehr guter Hardware, Full-SSD) bis vor kurzem problemlos am laufen (zunächst ab 2015 unter Win 8, später - nach Update - unter Win 10).

Nach längerer Zusi 3-Phase wollte ich mal wieder den Rhein entlang fahren - und wurde beim Laden der Strecke von der Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert." überrascht. Das Problem tritt reproduzierbar beim Laden aller Strecken auf (früher oder später beim Laden der (Landschafts-)Elemente). Ich behaupte, im letzten Jahr keine Änderung mehr an meinem Zusi 2 Datenbestand bzw. der Installation vorgenommen zu haben. Jedoch gab es ja vor einigen Wochen mal wieder ein größeres Win 10-Update (eine Vermutung ins Blaue...).

Installiert war/ist Zusi 2 noch unter C:\Program Files (x86)\Zusi. Ich habe zum Test Zusi 2 auch unter C:\ neu installiert, es trat jedoch derselbe Fehler auf, ebenso wie beim Ausführen als Administrator.
Auch eine Systemwiederherstellung der Zusi.exe auf eine Version von vor 1,5 Jahren brachte kein Erfolg.
Die Fahrsimulator-Version ist die Aktuelle: 2.4.7.4.

Bemerkenswert ist die Angabe des Kommas im errechneten Gleitkommawert - dies ist in der Tat kein gültiger Gleitkommawert. Die Einstellung des Dezimaltrennzeichens (unter "Systemsteuerung", "Zeit, Sprache und Region", "Datums-, Uhrzeit- oder Zahlenformat", "weitere Einstellungen") ist bei mir korrekt auf ".".

Kann mir jemand weiterhelfen? Für Hinweise bin ich dankbar. :)

Schöne Grüße,
Michael

Autor:  F. Schn. [ 06.11.2017 19:41:15 ]
Betreff des Beitrags:  Re: Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert."

Dann stell sie mal wieder korrekt auf "," um. Dann wird es vermutlich auch wieder gehen. :P

(Ja, Zusi 2 ist halt eine spezielle Software... :P )

Autor:  MCG [ 06.11.2017 21:45:01 ]
Betreff des Beitrags:  Re: Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert."

O-ha, ja, funktioniert wieder wunderbar. Vielen Dank!

Nach etwas Recherche habe ich die Vermutung, dass ich die Einstellung vielleicht mal im Zusammenhang mit Omsi 2 (läuft auch auf dem Rechner) geändert haben könnte. Ist mir zwar nicht mehr bewusst, aber Omsi 2 erwartet wiederum den "." als Gleitkommatrennzeichen.

(Für eine Software ist Zusi 2 ja auch definitiv im ehrenwerten Oldtimer-Alter angelangt. Und muss gerade deshalb umso mehr erhalten werden. ;D )

Schöne Grüße,
Michael

Autor:  Fabian Schöpflin [ 06.11.2017 21:49:50 ]
Betreff des Beitrags:  Re: Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert."

Im deutschsprachigen Raum werden Ziffern mit Punkten gruppiert und Dezimalzahlen mit Kommata getrennt.
Im englischsprachigen Raum erfolgt es genau anders herum. Vielleicht lag darin der Fehler.

Zusi 3 scheint im Übrigen abhängig von der gewählten regional abhängigen Formatierung keine Probleme damit zu haben.

Autor:  Johannes [ 06.11.2017 21:57:54 ]
Betreff des Beitrags:  Re: Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert."

Der Standard bei Formaten, die sowohl menschen- als auch maschinenlesbar sein sollen, ist der Punkt (klar -- da im englischsprachigen Raum verbreitet) und die Einleseroutine braucht sich dann um die Spracheinstellungen des Benutzers nicht zu kuemmern. Zusi 3 schreibt in XML-Dateien auch einen Punkt, aber versteht beim Lesen sowohl Punkt als auch Komma -- das faellt einem dann als Zusatzprogramm-Autor auf die Fuesse, weil man das auch unterstuetzen muss.

Autor:  Jan [ 09.11.2017 09:53:08 ]
Betreff des Beitrags:  Re: Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert."

Wobei ich meinen Rechner (allerdings Windows 7) auch seit langem mit den englischen Einstellungen für Dezimaltrennzeichen/Zifferngruppierung betreibe und ich mich an keine Probleme mit Zusi 2 erinnern kann. Hm...

Autor:  F. Schn. [ 09.11.2017 11:32:47 ]
Betreff des Beitrags:  Re: Fehlermeldung "'x,y' ist kein gültiger Gleitkommawert."

Es gibt soweit ich mich erinnere Unterschiede zwischen den Art- und Weisen, wie man das Dezimaltrennzeichen umstellt. Ich glaube dass sich die Einzelumstellung des Kommas anderst verhält als die Umstellung auf eine andere Sprachvorlage. Wenn ihr also da mal näher untersuchen wollt, solltet ihr ggf. mal darauf achten.

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/