Seite 1 von 1

Umbau eines BR112er MFA

Verfasst: 25.06.2021 21:48:51
von irFlouz
Hallo miteinander,
ich habe vor einer Weile ein 112er MFA auf eBay Kleinanzeigen gekauft, und jetzt wird es mal Zeit, dieses für Simulatoren (besonders für Zusi) zu ertüchtigen. Davor hatte ich zwar keine anderen Projekte dieser Art und dieser Größe durchgeführt, allerdings bin ich zuverlässig, dass ich es schaffen werde.
Ich hatte in diesem Forum bisher noch nie einen Thread oder einen Kommentar verfasst, weshalb man mich wohl nicht kennt. Also ganz kurz: Ich heiße (auch) Florian, komm ausm Schwabenländle und man kennt mich auch als FloribertHD.

Nun, zurück zum Thema: Ich hatte nun nach ein paar Wochen das MFA und begann dieses, auseinanderzunehmen und mal zu inspizieren. Die ganzen Platinen und das andere Zeugs, welches schlussendlich gegen einen Arduino ersetzt werden sollte wurde rausgenommen und vorerst mal in einem Schrank eingelagert. Bei genauerem Hinblick sind mir zwei Dinge aufgefallen: Ich hatte mir aus Versehen ein 112er MFA, also eins ohne Fahrstufenanzeiger, gekauft und nicht eines aus einem x-Wagen Führerstand. Das ist aber nicht so schlimm, wird halt hingenommen.
Nun das zweite, größere Problem: Beim Transport ist die Zugkraftnadel abgefallen oder abgebrochen, sie liegt nun im Zugkraftanzeiger drinne. Hier bin ich noch recht ideenlos denn ich hatte gelesen, dass die Zeiger ziemlich empfindlich seien und man daran eher weniger fummeln sollte. Sollte jemand eine Idee zum Reparieren haben, kann sie bitte hier teilen.
Bild

Trotzdem hatte ich mal die Teile zum Fachlehrer meiner Schule gebracht, um zusammen mal zu überprüfen, welche Bauteile welche Spannung benötigen, ich selber besitze nicht die nötigen Messgeräte. Am MFA selbst standen 24V Gleichspannung, also höher als das sollte es nicht gehen. Bei den Leuchtmeldern und der Instrumentenbeleuchtung hatten auch 24V gepasst, jedoch hatten die Instrumente ein paar Abweichungen: So standen am Amperemeter selbst, dass dieses bis zum Anschlag auf beiden Seiten eine Spannung von 10,8V bzw. -10,8V benötigt, jedoch brauchte es stattdessen ungefähr 20V in beide Richtungen, am äußeren Zeiger sogar ungefähr 27V. Das ginge über die 24V, welche ich ebenfalls nach dem Umbau einsetzen werde, also ein anderer Stein im Weg. Das Tachometer konnte ich aufgrund der Anschlüsse noch nicht testen, weshalb es dort wohl eher sofort einen Umbau geben würde, außer falls jemand zufälligerweise die Anschlüsse kennt.
Bild

Nun zur Planung: Ich plane aktuell, die Steuerung mit einem Arduino Leonardo + Ethernet Shield und evtl. einem weiteren Arduino Mega durchzuführen, der Strom wird aus einem Netzteil, welches für Laptops und derähnlichen ist (besagte 24V), und damit der Steckdose bezogen, dieser 24V-Stromkreis wird dann durch Transistoren geschaltet. Schaltskizzen oder derähnlichen habe ich noch nicht, denn ich muss wohl zuerst das Tachometer auseinanderbauen, sodass ich weiß, wie ich dieses ansteuern muss. Sonst eigentlich eher simpel.

Des wär's mal für jetzt, ich werde ab und zu mal hier Neuigkeiten posten, sollte es etwas neues geben. Kann aber dauern, denn bei mir braucht das meiste immer seine Zeit :P
Mit freundlichen Grüßen
irFlouz (Florian)

Re: Umbau eines BR112er MFA

Verfasst: 29.06.2021 22:35:41
von nonesense
Hallo Florian,

hast du den Beitrag zu meinem Fahrpult gesehen?: https://www.forum.zusi.de/viewtopic.php?f=25&t=13875
Dort schreibe ich über meine MFA-Umbauten. Zuerst eins ohne LZB, dann ein anders mit LZB.

Was du über die Empfindlichkeit der Zeiger gelesen hast, wird wohl von mir stammen. Das Zeigerkreutz ist so ausbalanciert, dass du einen Linearen Verlauf zwischen Spannung und Zeigerposition hast. Wenn du zusätzliches Gewicht einbringst, z.B. durch Sekundenkleber oder du Teile verbiegst, ist der Verlauf nicht mehr Linear. Das wird in deinem Fall aber nicht zu vermeiden sein, wenn du das Gerät nicht vom Hersteller reparieren lässt. Das kannst du aber auch durch die Software im Arduino kompensieren.

Gruß
Jens

Endlich Fortschritt - LM blinkt

Verfasst: 14.09.2021 21:16:57
von irFlouz
Guten Abend,
nach... 3 Monaten gibt's endlich Fortschritte - zuvor hat mal das Material, mal die Motivation gefehlt, mal hatte ich keine Zeit und für eine längere Zeit standen die Komponenten des MFAs im Eck vom Zimmer. Jedenfalls hab ich mich in den letzten Tagen mal wieder drangesetzt und währenddessen drei von vier Transistoren, welche ich von meinem Fachlehrer vor den Sommerferien bekommen habe, beschädigt, weil scheinbar keiner von uns beiden begriffen hat, dass die zulässige Stromstärke der Transistoren trotz vorherigem Nachmessen zu gering war. Nach ausreichender Recherche bin ich dann zum nächsten Conrad gegangen und habe gscheite Transistoren geholt. Nach einer kleinen Anpassung der Prototypschaltung konnte ich dann folgenden Erfolg verzeichnen:
https://youtu.be/O0JIUhclfNI
Hier hab ich dann mit meinem Arduino und meiner Schaltung dann den 500Hz-LM zum blinken gebracht, und zum Testen fürs spätere Dimmen auch gleich mit ein- und ausblenden.

Jetzt geht's darum, die ganze Schaltung zu vervierzehnfachen und das auf eine Platine zu bringen, und dann das ganze dann mit Zusi zum laufen zu bringen. Ach ja und das mit den Zeigern, da muss ich auch noch ran, aber jetzt noch nicht.
nonesense hat geschrieben: 29.06.2021 22:35:41 Hallo Florian,

hast du den Beitrag zu meinem Fahrpult gesehen?: https://www.forum.zusi.de/viewtopic.php?f=25&t=13875
Dort schreibe ich über meine MFA-Umbauten. Zuerst eins ohne LZB, dann ein anders mit LZB.

Was du über die Empfindlichkeit der Zeiger gelesen hast, wird wohl von mir stammen. Das Zeigerkreutz ist so ausbalanciert, dass du einen Linearen Verlauf zwischen Spannung und Zeigerposition hast. Wenn du zusätzliches Gewicht einbringst, z.B. durch Sekundenkleber oder du Teile verbiegst, ist der Verlauf nicht mehr Linear. Das wird in deinem Fall aber nicht zu vermeiden sein, wenn du das Gerät nicht vom Hersteller reparieren lässt. Das kannst du aber auch durch die Software im Arduino kompensieren.

Gruß
Jens
Hallo Jens,
ja, des müsste dein Beitrag gewesen sein, den ich gelesen hatte. Jedenfalls werd' ich wohl beide Anzeigen aufschrauben müssen, ich komm' wohl nicht drum. Ach ja, und vielen Dank für deinen Beitrag, er hat mir sehr geholfen :D

Dann sieht' man sich wohl erst wieder in einer Weile, bis mal die Platine entworfen und hergestellt wurde. Bis dann!

Mfg Florian

Re: Umbau 112er MFA

Verfasst: 29.09.2021 16:09:54
von _TheDragonRider_
Hallo Florian,

ich bin kürzlich ebenfalls in den Besitz einer MFA gekommen (allerdings Br 155) und habe das selbe Problem, das die Zugkraftnadel sich bei der Lieferung verabschiedet hat. Ich bin gerade daran am verzweifeln den Tacho zu öffnen und wollte fragen, ob und wie du es geschafft hattest.

MfG, Paul

Re: Umbau eines BR112er MFA

Verfasst: 29.09.2021 21:46:45
von Formsignal
_TheDragonRider_ hat geschrieben: 29.09.2021 16:09:54 Ich bin gerade daran am verzweifeln den Tacho zu öffnen und wollte fragen, ob und wie du es geschafft hattest.
Das ist eigentlich bei allen Deuta-Instrumenten ähnlich: Der umgebördelte Rand muss wieder durch aufbiegen geöffnet werde, dann lässt sich der Frontrahmen und die Glasscheibe herausnehmen. Die Schrauben/Muttern von der Rückseite (Anschlüsse) müssen ebenso gelöst werden, anschließend sollte sich das "Innenleben" aus dem Gehäuse nehmen lassen.