Zusi-Exchange 2.1.1.2

Alles rund um die Downloadbörse von Max Senft
Antworten
Nachricht
Autor
Benutzeravatar
Max Senft
Administrator
Beiträge: 3004
Registriert: 04.11.2001 14:01:40
Aktuelle Projekte: Dies und das
Wohnort: Blieskastel, Saarland, Deutschland
Kontaktdaten:

Zusi-Exchange 2.1.1.2

#1 Beitrag von Max Senft »

Hi @ll,

ab sofort gibt es die Version 2.1.1.2 zum Download - wie immer - auf http://www.zusi-exchange.de!

Wegen den Bugfixes geht bitte auf die extra dafür erstellte Seite! ;)

Ich hoffe der "Closed Gracefully"-Fehler kommt nichmehr. ?(

Bye
Max Senft

Benutzeravatar
Christian_Omlin
Beiträge: 67
Registriert: 04.11.2001 17:39:52
Aktuelle Projekte: RhB: Albulabahn
Wohnort: Wil/SG (CH)

#2 Beitrag von Christian_Omlin »

Hallo Max!

Das ist zwar alles schön und gut, aber die Schweizer (oder zumindestens ich) befinden sich immernoch auf dem Abstellgleis.
Bei mir taucht seit längerer Zeit der Fehler " is not an integer value auf. Zudem kommen noch etwa ein halbes Dutzend Fehlermeldungen und Exchange schliesst sich wieder. Lässt sich da nicht etwas machen?

Gruss
Christian

Benutzeravatar
Max Senft
Administrator
Beiträge: 3004
Registriert: 04.11.2001 14:01:40
Aktuelle Projekte: Dies und das
Wohnort: Blieskastel, Saarland, Deutschland
Kontaktdaten:

#3 Beitrag von Max Senft »

Hi,

nun doch, klar. Was kommen denn noch alles für Fehlermeldungen?

Bye
Max Senft

Benutzeravatar
Stefan Hums
Beiträge: 2406
Registriert: 05.11.2001 21:14:24
Wohnort: Erlbach (Vogtland)

#4 Beitrag von Stefan Hums »

@Max:
Proxy-Einstellungen funktionieren. Bitte nicht wieder kaputtbasteln. ;D

Stefan

Benutzeravatar
Max Senft
Administrator
Beiträge: 3004
Registriert: 04.11.2001 14:01:40
Aktuelle Projekte: Dies und das
Wohnort: Blieskastel, Saarland, Deutschland
Kontaktdaten:

#5 Beitrag von Max Senft »

Hi,

nee nee, keine Sorge. Ich hab nur vergessen gehabt ne Prozedur aufzurufen.

Bye
Max Senft

Benutzeravatar
Christian_Omlin
Beiträge: 67
Registriert: 04.11.2001 17:39:52
Aktuelle Projekte: RhB: Albulabahn
Wohnort: Wil/SG (CH)

#6 Beitrag von Christian_Omlin »

Gut!

EConvertError
" is not a valid integer value
Falscher Versionsstring:
Line 235

Dann kommt 7x das gleiche mit den Linien 248, 261, 273, 235, 248, 261 und nochmal 273

Und dann: Sie haben eine falsche Message DLL!
Benutzte Version: 0.0.0.0
Benötigte Version: 0.3.0.5

Gruss
Christian

Benutzeravatar
Felix_Aeschimann
Beiträge: 512
Registriert: 06.11.2001 20:02:46
Aktuelle Projekte: Gotthardbahn
Wohnort: Dielsdorf (Schweiz)
Kontaktdaten:

#7 Beitrag von Felix_Aeschimann »

...Schliesse mich den Ausführungen meines Kollegen an... X(

Benutzeravatar
Steven De Haeck
Beiträge: 109
Registriert: 13.05.2002 23:46:12
Wohnort: Halle (Belgien)

#8 Beitrag von Steven De Haeck »

Schliesse mich auch an.

Steven
Halle (Belgien)

FloH
Beiträge: 167
Registriert: 13.05.2002 19:49:14
Wohnort: Zorneding bei München
Kontaktdaten:

#9 Beitrag von FloH »

Hallo,

bin ich hier der einzige bei dem die neue Version funzt??? :wow

Flo

LutzD
Beiträge: 64
Registriert: 04.11.2001 18:56:08
Wohnort: Braunschweig

#10 Beitrag von LutzD »

Hallo!

Nein bei mir funzt es auch, nach einem kleinen Firewallproblem.

Gruß LutzD :schiel

Al Fli
Beiträge: 38
Registriert: 06.11.2001 21:00:02
Wohnort: Wien
Kontaktdaten:

#11 Beitrag von Al Fli »

Hallo,

bei mir funkts genausowenig wie bei den schweizer Kollegen. :§$%

Al

Benutzeravatar
Roland Ziegler
Beiträge: 5516
Registriert: 04.11.2001 22:09:26
Wohnort: 32U 0294406 5629020
Kontaktdaten:

#12 Beitrag von Roland Ziegler »

Auch ich melde noch einen kleinen Bug:

Beim Versuch, zu einem DB-Eintrag das Bild anzuzeigen, macht Exchange zwar den Viewer auf (bei mir ist das momentan IE) und stellt das Bild dar, verabschiedet sich aber gleichzeitig mit folgender allumfassender Fehlermeldung:

EXCHANGE2 verursachte eine allgemeine Schutzverletzung
in Modul <Unbekannt> bei e2c6:00006775.
Register:
EAX=bff66821 CS=017f EIP=00006775 EFLGS=00010246
EBX=0072f484 SS=0187 ESP=00630048 EBP=00630064
ECX=006300e8 DS=017f ESI=819938e4 FS=511f
EDX=bff6682d ES=0187 EDI=00630110 GS=0000
Bytes bei CS:EIP:
8f 06 70 06 8f 06 6e 06 c6 06 66 06 01 c6 06 67
Stapelwerte:
00630110 0072f484 0063012c 006300e8 00630218 bff6682d 0072f484 006300f8 bff7845a 00630110 0072f484 0063012c 006300e8 00006770 006302d0 819938e4

Mirko
Beiträge: 3410
Registriert: 04.11.2001 20:39:16
Aktuelle Projekte: Nothing in particular
Wohnort: Erftstadt
Kontaktdaten:

#13 Beitrag von Mirko »

Hi!

Im Prinzip funktioniert´s, aber...
Die Liste der bereits geladenen Dateien wurde bei der Deinstall der Vorversion offenbar entfernt oder von der neuen Version mit einer leeren Datei überschrieben. Auf jeden Fall kann man alle Dateien perHand als geladen markieren, die man schon hat :§$% :§$% :§$%
Immerhin nehme ich sowieso nur leuchtend grün hinterlegte Dateien - das vereinfacht es etwas!

Mirko
Man sollte sich immer gut überlegen, was man sich wünscht. Manchmal passiert es, dass man es kriegt (Meat Loaf)

Benutzeravatar
Felix_Aeschimann
Beiträge: 512
Registriert: 06.11.2001 20:02:46
Aktuelle Projekte: Gotthardbahn
Wohnort: Dielsdorf (Schweiz)
Kontaktdaten:

#14 Beitrag von Felix_Aeschimann »

Macht irgendwie den Anschein das Exchange ein Germany-Only-Programm ist. ;(

Benutzeravatar
Roland Ziegler
Beiträge: 5516
Registriert: 04.11.2001 22:09:26
Wohnort: 32U 0294406 5629020
Kontaktdaten:

#15 Beitrag von Roland Ziegler »

Die Erfindung der Locale hat sich möglicherweise noch nicht bei alle Delphi-Entwicklern rumgesprochen.:O

Benutzeravatar
Max Senft
Administrator
Beiträge: 3004
Registriert: 04.11.2001 14:01:40
Aktuelle Projekte: Dies und das
Wohnort: Blieskastel, Saarland, Deutschland
Kontaktdaten:

#16 Beitrag von Max Senft »

Hi Rainer,

was meinst du mit Locale? Der Fehler kommt nur, weil er Versionsinformationen nicht findet. Beim Braunschweig Treffen hab ich mir die Geschichte mal angeschaut. Dort habe ich herausgefunden, dass, wie schon gesagt, Versionsinformationen fehlen. Ich weiß zwar nicht wieso. Aber es ist so. Sehr seltsam das ganze. Ich habe mal diese Versionsprüfung, die dann schließlich zum Beenden des Programms führt, entfernt. War sowieso unwichtig.

Bye
Max Senft

Benutzeravatar
Roland Ziegler
Beiträge: 5516
Registriert: 04.11.2001 22:09:26
Wohnort: 32U 0294406 5629020
Kontaktdaten:

#17 Beitrag von Roland Ziegler »

Hallo Max,

ich hatte den Eindruck, dass es sich um länderspezifische Einstellungen handeln könnte, nach den Meldungen, warum Exchange in der Schweiz ein "Non-Starter" ist - auch Carsten hatte ja Probleme.

Und für die gesammelten länderspezifischen Einstellungen haben sich die Programmiersprachentwickler vor ca 10 Jahren die sogenannte Locale einfallen lassen. Über die kann man da beliebige Änderungen machen bei Dezimaltrennzeichen, Datumsdarstellung, Währung und all so´n Kram. Das ist auch zunächst unabhängig vom Betriebsystem. Soweit ich verstanden habe, sollte es die Locale auch unter Delphi geben. 8)

Möglicherweise startet Delphi defaultmäßig mit lokalen Ländereinstellungen - was ich für ziemlich merkwürdig halte ?( . Man muss also dafür sorgen, dass dieser lokale Einfluss unterdrückt wird, bzw., wenn das Kind schon in den Brunnen gefallen ist, die Gesamt-Locale explizit auf Deutsch setzen (unter Unix heißt sie dann "de_de", unter Windows "German").

Bei Zusi führte ja die implizite Locale zu dem merkwürdigen Floating-Point-Format mit Komma in allen Dateien, zwar schön eingedeutscht, aber sonst sehr, sehr exotisch :sick .

Antworten